summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.dev>2023-07-17 15:59:05 +0200
committerNiklas Haas <github-daiK1o@haasn.dev>2023-08-18 16:39:57 +0200
commit24dca265b45fc07e0bb193ea87e36931ce459f7d (patch)
tree18a15e2c20402dbb309918dd479b1d47e6e7a077 /meson.build
parente3ae0724140f8c333670ac7a08cac865dcb9a576 (diff)
downloadmpv-24dca265b45fc07e0bb193ea87e36931ce459f7d.tar.bz2
mpv-24dca265b45fc07e0bb193ea87e36931ce459f7d.tar.xz
meson: remove redundant libplacebo-next check
Now implied by the minimum libplacebo version.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 3 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index 8a7d7d2b0e..7eb6f95cb2 100644
--- a/meson.build
+++ b/meson.build
@@ -934,16 +934,8 @@ features += {'libplacebo': libplacebo.found()}
if features['libplacebo']
dependencies += libplacebo
sources += files('video/out/placebo/ra_pl.c',
- 'video/out/placebo/utils.c')
-endif
-
-libplacebo_next = get_option('libplacebo-next').require(
- features['libplacebo'] and libplacebo.version().version_compare('>=5.264.0'),
- error_message: 'libplacebo v5.264.0+ was not found!',
-)
-features += {'libplacebo-next': libplacebo_next.allowed()}
-if features['libplacebo-next']
- sources += files('video/out/vo_gpu_next.c',
+ 'video/out/placebo/utils.c',
+ 'video/out/vo_gpu_next.c',
'video/out/gpu_next/context.c')
endif
@@ -1779,7 +1771,7 @@ if get_option('tests')
endif
summary({'d3d11': features['d3d11'],
- 'gpu-next': features['libplacebo-next'],
+ 'gpu-next': features['libplacebo'],
'javascript': features['javascript'],
'libmpv': get_option('libmpv'),
'lua': features['lua'],