summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorder richter <der.richter@gmx.de>2023-11-07 21:47:30 +0100
committerder richter <der.richter@gmx.de>2023-11-10 14:28:39 +0100
commit1c98ab623955957c8fa9aea4c39b1f48379e3c92 (patch)
treeb4aed338a3025a64eb1dd426f4f8f1cec043ce5c /meson.build
parentb4e14b9420f1d419b3a32f287a8ff9d0911ebc85 (diff)
downloadmpv-1c98ab623955957c8fa9aea4c39b1f48379e3c92.tar.bz2
mpv-1c98ab623955957c8fa9aea4c39b1f48379e3c92.tar.xz
TOOLS/macos-sdk-version: remove legacy sdk version retrieval
older macOS dev tools were inconsistent with the way how SDK versions were returned, some truncated the minor versions. in those cases the SDK version had to be retrieved through the SDK build version. recently the scheme for the SDK build version changed that our heuristic for converting it to an SDK version produced wrong version strings. the stride of the minor version changed from 1 to 2, so SDK versions ended up higher than they actually were. furthermore macOS 11 was hardcoded. since Xcode 12 Apple fixed the SDK version retrieval and it is no longer truncated when using Xcode as dev tools. Xcode 12 is also the latest supported version on macOS 10.15, which is also our oldest supported version. we can remove the old SDK build version conversation and use the Xcode only tool to retrieve the SDK version in the case Xcode is used as dev tools. furthermore this als keeps support for Xcode 11 where the problem wasn't fixed yet, but is still a supported version on macOS 10.15. Fixes #9907
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index f9c29cdaa8..bbd6b78b28 100644
--- a/meson.build
+++ b/meson.build
@@ -1464,10 +1464,8 @@ macos_sdk_path = ''
macos_sdk_version = '0.0'
if darwin and macos_sdk_version_py.found()
macos_sdk_info = run_command(macos_sdk_version_py, check: true).stdout().split(',')
- macos_sdk_path = macos_sdk_info[0].strip()
- # Always pick whichever version is higher.
- macos_sdk_version = macos_sdk_info[1].version_compare('>' + macos_sdk_info[2]) ? \
- macos_sdk_info[1] : macos_sdk_info[2]
+ macos_sdk_path = macos_sdk_info[0]
+ macos_sdk_version = macos_sdk_info[1]
endif
if macos_sdk_path != ''