summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-10-05 13:59:55 -0500
committerDudemanguy <random342@airmail.cc>2023-11-27 18:42:19 +0000
commit0ea374b1c78156f83a7544458dbd058c744deef3 (patch)
tree902dbf12ce5f065812fd17d1b993a45e0d8b303f /meson.build
parent1b035402a688a5d116a9014e8930d7863481eeed (diff)
downloadmpv-0ea374b1c78156f83a7544458dbd058c744deef3.tar.bz2
mpv-0ea374b1c78156f83a7544458dbd058c744deef3.tar.xz
meson: generate .com in the same place as the .exe if possible
Meson was pretty strict about target ids and generating the mpv.com in the same directory as mpv.exe wasn't possible. So as a workaround we tucked it away in a subdirectory, but that's not really intuitive at all. Well as of meson 1.3.0, this is now possible so leverage it since it makes way more sense. We still keep the old workaround for anyone using older meson versions.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0ff16b42d9..a47aa54ce2 100644
--- a/meson.build
+++ b/meson.build
@@ -1686,6 +1686,13 @@ features += {'libmpv-' + get_option('default_library'): get_option('libmpv')}
# build targets
if win32
+ # Older meson versions generate this in the player subdirectory.
+ if get_option('cplayer') and meson.version().version_compare('>= 1.3.0')
+ wrapper_sources= 'osdep/win32-console-wrapper.c'
+ executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
+ name_suffix: 'com', install: true)
+ endif
+
windows = import('windows')
res_flags = ['--codepage=65001']