summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@overt.org>2022-07-31 11:50:57 -0700
committerPhilip Langdale <github.philipl@overt.org>2022-08-03 16:56:17 -0700
commit06900eef63c112fc9404f649daf31de334711bbc (patch)
treec0ac337a38b5667c064bf597096cd53808acb298 /meson.build
parent490e263529a5e49e8a7b6d9c6c21a1312f3ac1a4 (diff)
downloadmpv-06900eef63c112fc9404f649daf31de334711bbc.tar.bz2
mpv-06900eef63c112fc9404f649daf31de334711bbc.tar.xz
hwdec/vaapi: rename interops to reflect more general use
This is the first in a series of changes that will introduce a drmprime hwdec. As our vaapi hwdec is based around exporting surfaces as drmprime dmabufs, we've actually got a lot of useful code already in place in the GL/PL interops. I'm going to reorganise and adjust this code to make the interops usable with the new hwdec as well. The first step is to rename the files and functions. There are no functional or other changes here. They will come next.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 920230a301..20dc9bb437 100644
--- a/meson.build
+++ b/meson.build
@@ -1474,7 +1474,7 @@ vaapi_egl = {
if vaapi_egl['use']
dependencies += [vaapi_wayland['deps'], vaapi_drm['deps']]
features += vaapi_egl['name']
- sources += files('video/out/hwdec/hwdec_vaapi_gl.c')
+ sources += files('video/out/hwdec/dmabuf_interop_gl.c')
endif
vaapi_libplacebo = {
@@ -1483,7 +1483,7 @@ vaapi_libplacebo = {
}
if vaapi_libplacebo['use']
features += vaapi_libplacebo['name']
- sources += files('video/out/hwdec/hwdec_vaapi_pl.c')
+ sources += files('video/out/hwdec/dmabuf_interop_pl.c')
endif
if vaapi_egl['use'] or vaapi_libplacebo['use']