summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@overt.org>2022-08-27 09:53:31 -0700
committerPhilip Langdale <github.philipl@overt.org>2022-10-11 10:07:48 -0700
commit064059e6c36329e1b1fd567d0efdfbaf13ec53c4 (patch)
tree154a9afe75e3288499da84ffb9157166c81c60bb /meson.build
parentd050e350fee8b3bef3f77e9c161bf35aea8faa2e (diff)
downloadmpv-064059e6c36329e1b1fd567d0efdfbaf13ec53c4.tar.bz2
mpv-064059e6c36329e1b1fd567d0efdfbaf13ec53c4.tar.xz
vo_gpu/hwdec: rename and introduce legacy names for some interops
We've had some annoying names for interops, which we can't simply rename because that would break config files and command lines. So we need to put a little more effort in and add a concept of legacy names that allow us to continue loading them, but with a warning. The two I'm renaming here are: * vaapi-egl -> vaapi (vaapi works with Vulkan too) * drmprime-drm -> drmprime-overlay (actually describes what it does) * cuda-nvdec -> cuda (cuda interop is not nvdec specific)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 244977dc9c..2783490a2e 100644
--- a/meson.build
+++ b/meson.build
@@ -900,8 +900,8 @@ if features['drm']
'video/out/drm_atomic.c',
'video/out/drm_common.c',
'video/out/drm_prime.c',
- 'video/out/opengl/hwdec_drmprime_drm.c',
'video/out/hwdec/hwdec_drmprime.c',
+ 'video/out/hwdec/hwdec_drmprime_overlay.c',
'video/out/vo_drm.c')
endif