summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2022-11-20 12:04:04 -0600
committerDudemanguy <random342@airmail.cc>2022-11-20 12:04:04 -0600
commit04f765da6fb407c7ebe1833403a6049e2c9df6ce (patch)
tree3693f88653c7933d8adabc53e69db30090edc88b /meson.build
parentf10b24e3c5c76756544830f2a9ef192f55a7dcdb (diff)
downloadmpv-04f765da6fb407c7ebe1833403a6049e2c9df6ce.tar.bz2
mpv-04f765da6fb407c7ebe1833403a6049e2c9df6ce.tar.xz
meson: unbreak dl check on BSDs without libdl
Regression from 1835dfc05c8298262dbf8e08a31d61bbfecdb30b. The actual libdl dependency is not always required for the function symbol check. Fixes #10901.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 14b9616f92..c2916d5fb9 100644
--- a/meson.build
+++ b/meson.build
@@ -327,7 +327,7 @@ endif
features += {'ta-leak-report': get_option('ta-leak-report')}
libdl_dep = cc.find_library('dl', required: false)
-features += {'libdl': libdl_dep.found() and cc.has_function('dlopen', dependencies: libdl_dep, prefix: '#include <dlfcn.h>')}
+features += {'libdl': cc.has_function('dlopen', dependencies: libdl_dep, prefix: '#include <dlfcn.h>')}
if features['libdl']
dependencies += libdl_dep
endif