summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@overt.org>2023-05-29 12:40:35 -0700
committerPhilip Langdale <github.philipl@overt.org>2023-05-29 13:26:29 -0700
commit0131ae4133a2f442fe1906d1632c4b84954c4140 (patch)
treea61f88aefaa2e4b475a323491a23ff0b93b9f080 /meson.build
parentba5370e82a1139a249f27b78d22e8fe4092ad024 (diff)
downloadmpv-0131ae4133a2f442fe1906d1632c4b84954c4140.tar.bz2
mpv-0131ae4133a2f442fe1906d1632c4b84954c4140.tar.xz
hwdec_vulkan: simplify requirement checks for Vulkan interop
I originally wrote this trying to avoid doing an explicit version check on the headers, but it just makes things more confusing, and the requirements harder to understand. So, Vulkan interop now takes a dependency on the header release where they finalised the video decode headers. VK_EXT_descriptor_buffer was added in 1.3.235, so that's covered as well. Along the way I fixed a bug in the waf build where it was depending on libplacebo-next instead of libplacebo-decode.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index d03fe823a4..812f97cc98 100644
--- a/meson.build
+++ b/meson.build
@@ -933,8 +933,6 @@ if features['libplacebo-next']
'video/out/gpu_next/context.c')
endif
-features += {'libplacebo-decode': features['libplacebo'] and libplacebo.version().version_compare('>=5.275.0')}
-
sdl2_video = get_option('sdl2-video').require(
features['sdl2'],
error_message: 'sdl2 was not found!',
@@ -1312,9 +1310,10 @@ if features['cuda-interop'] and features['vulkan']
endif
vulkan_interop = get_option('vulkan-interop').require(
- vulkan.found() and features['libplacebo-decode'] and
+ features['vulkan'] and vulkan.version().version_compare('>=1.3.238') and
+ features['libplacebo'] and libplacebo.version().version_compare('>=5.278.0') and
libavutil.version().version_compare('>=58.11.100'),
- error_message: 'Vulkan Interop requires vulkan, libplacebo >= 5.275.0, and libavutil >= 58.11.100',
+ error_message: 'Vulkan Interop requires vulkan headers >= 1.3.238, libplacebo >= 5.278.0, and libavutil >= 58.11.100',
)
features += {'vulkan-interop': vulkan_interop.allowed()}
if vulkan_interop.allowed()