summaryrefslogtreecommitdiffstats
path: root/generated/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2022-05-04 15:09:48 -0500
committerDudemanguy <random342@airmail.cc>2022-05-05 13:04:15 +0000
commit3a4537d40be9a1b11ca1719d7e34b166bcfb293b (patch)
tree4a22d82c109ff0ad4aea0b8e08e21d513f2f098c /generated/meson.build
parent76f888f5551f486b6d0c9b9c3a0f17e1e0bf9d71 (diff)
downloadmpv-3a4537d40be9a1b11ca1719d7e34b166bcfb293b.tar.bz2
mpv-3a4537d40be9a1b11ca1719d7e34b166bcfb293b.tar.xz
meson: compile mpv.exe as a win32 gui application
Some compiler flags were passed to mpv in order to get it to build as a gui application on windows. However on the meson build, this always resulted in mpv being built as a console application. This is because the function for making executables in meson specifically has a kwarg called win_subsystem* which defaults to 'console'. That always added link arguments at the end which compiled mpv.exe as a console application. The correct thing to do is to remove all of the subsystem-related flags in the meson build and use the win_subsystem kwarg as intended by setting it to 'windows,6.0'. For mpv.com, we can remove the -Wl,--subsystem,console flag since meson will set this by default in that executable. This makes mpv.exe function correctly and open with the pseudo-gui while mpv.com acts as a console wrapper. https://github.com/mesonbuild/meson/commit/1a0603835e3c9f1047d9b7694efc996219a422e4
Diffstat (limited to 'generated/meson.build')
-rw-r--r--generated/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/generated/meson.build b/generated/meson.build
index 1104bdc21a..fe3e78c47f 100644
--- a/generated/meson.build
+++ b/generated/meson.build
@@ -20,8 +20,7 @@ sources += [ebml_defs, ebml_types, version_h]
# Just generate the com in here for windows builds.
if win32 and get_option('cplayer')
features += 'win32-executable'
- wrapper_flags = ['-municode', '-Wl,--subsystem,console']
wrapper_sources= '../osdep/win32-console-wrapper.c'
- executable('mpv', wrapper_sources, c_args: wrapper_flags, link_args: wrapper_flags,
+ executable('mpv', wrapper_sources, c_args: '-municode', link_args: '-municode',
name_suffix: 'com', install: true)
endif