summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorUoti Urpala <uau@glyph.nonexistent.invalid>2009-08-18 02:29:37 +0300
committerUoti Urpala <uau@glyph.nonexistent.invalid>2009-08-18 02:29:37 +0300
commit95da34aa071d64b21ef3e952b987ba3dcee84ca0 (patch)
treeeabf4399e40fd270714c53d40688eadadfd4c5ff /debian
parentf394231f5de9d1ff679f1b2da4d1f1b303ae914a (diff)
parent3961e12fca2f1ec10c64e3ff298828feecca52c9 (diff)
downloadmpv-95da34aa071d64b21ef3e952b987ba3dcee84ca0.tar.bz2
mpv-95da34aa071d64b21ef3e952b987ba3dcee84ca0.tar.xz
Merge svn changes up to r29532
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c486af5dff..17c06b0621 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,9 @@ prefix := $(shell pwd)/debian/$(package)
arch := $(shell dpkg --print-architecture)
+# See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
+# https://wiki.ubuntu.com/DistCompilerFlags
+CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
configure: configure-stamp
configure-stamp:
@@ -19,6 +22,7 @@ configure-stamp:
# If you plan to install the target .deb on a wide variety of machines,
# you may want to add the "--enable-runtime-cpudetection" option to
# the line below, but beware: the resulting binary will run slower
+ $(CLEAN_ENV) \
./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_OPTIONS)
touch configure-stamp
@@ -28,6 +32,7 @@ build-stamp:
dh_testdir
# commands to compile the package.
+ $(CLEAN_ENV) \
${MAKE}
touch build-stamp