summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authordiego <diego@b3059339-0415-0410-9bf9-f77b7e298cf2>2002-08-27 09:57:12 +0000
committerdiego <diego@b3059339-0415-0410-9bf9-f77b7e298cf2>2002-08-27 09:57:12 +0000
commit8c39272f0afb035340c9c196317bd1fbe377f4de (patch)
treea6819793f5fc1a71ea667b313d12e0cd0e1eb76a /debian
parenta3ce1c658aa10a1f6d18c4f47e4314ca5339b9d1 (diff)
downloadmpv-8c39272f0afb035340c9c196317bd1fbe377f4de.tar.bz2
mpv-8c39272f0afb035340c9c196317bd1fbe377f4de.tar.xz
Use the confdir we compiled with (/etc/mplayer/mplayer.conf instead of
/etc/mplayer.conf). Spotted by Kiss Gabor <kissg@sztaki.hu>. git-svn-id: svn://svn.mplayerhq.hu/mplayer/trunk@7097 b3059339-0415-0410-9bf9-f77b7e298cf2
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/config2
-rwxr-xr-xdebian/postinst8
-rw-r--r--debian/postinst.templates6
4 files changed, 15 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index d76c81548b..796c8cab8e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mplayer (0.90-2) unstable; urgency=low
+
+ * Use the confdir we compile with in the helper scripts
+ (/etc/mplayer/mplayer.conf instead of /etc/mplayer).
+
+ -- Diego Biurrun <diego@biurrun.de> Tue, 27 Aug 2002 11:18:50 +0200
+
mplayer (0.90-1) unstable; urgency=low
* 0.90 release including latest alsa9 fixes
diff --git a/debian/config b/debian/config
index 3084a67bdb..5a342d139c 100755
--- a/debian/config
+++ b/debian/config
@@ -19,7 +19,7 @@ checkupgrade(); # Find out if we have to upgrade.
mainloop(letsgo());
sub checkupgrade {
- open(MCFG, "</etc/mplayer.conf") || return 1;
+ open(MCFG, "</etc/mplayer/mplayer.conf") || return 1;
my $line = <MCFG>;
return 1 if ($line =~ /mplayer DEBCONF AREA/);
exit(0) if (input($PRIORITY, 'mplayer/replace-existing-files') eq "question skipped");
diff --git a/debian/postinst b/debian/postinst
index 5653828639..85fc11e227 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -13,7 +13,7 @@ my $didupgrade = 0;
dealwithupgrades();
-my $mcfg = new ConfHelper('mplayer', "/etc/mplayer.conf");
+my $mcfg = new ConfHelper('mplayer', "/etc/mplayer/mplayer.conf");
$mcfg->setconfarea("
#MPlayer config file generated by .deb package.
#ffactor = 0.9
@@ -48,10 +48,10 @@ get("mplayer/cfgnote");
sub dealwithupgrades {
- open(OLDCONF, "</etc/mplayer.conf") || return 1;
+ open(OLDCONF, "</etc/mplayer/mplayer.conf") || return 1;
close OLDCONF;
- my $mconf = new ConfHelper("mplayer", "/etc/mplayer.conf");
+ my $mconf = new ConfHelper("mplayer", "/etc/mplayer/mplayer.conf");
return 1 if ($mconf->hasconfarea());
undef $mconf;
@@ -60,7 +60,7 @@ sub dealwithupgrades {
print STDERR "Upgrading...\n";
#? saveolddata("/etc/network/interfaces", "pppconf");
$didupgrade = 1;
- for my $file ("/etc/mplayer.conf"
+ for my $file ("/etc/mplayer/mplayer.conf"
#, "/etc/mplayer/fonts/sth
) {
debug("Deleting $file");
diff --git a/debian/postinst.templates b/debian/postinst.templates
index 08339d204b..80c871afd1 100644
--- a/debian/postinst.templates
+++ b/debian/postinst.templates
@@ -17,14 +17,14 @@ Description: Which Video Output driver would you like?
Template: mplayer/overwrite
Type: boolean
Default: false
-Description: Overwrite /etc/mplayer.conf ?
- Should I overwrite your current /etc/mplayer.conf with the one created on the fly based on your answers?
+Description: Overwrite /etc/mplayer/mplayer.conf ?
+ Should I overwrite your current /etc/mplayer/mplayer.conf with the one created on the fly based on your answers?
Template: mplayer/cfgnote
Type: note
Description: Create your ~/.mplayer/conf file.
Remember to read documentation and edit your ~/.mplayer/conf
- (or /etc/mplayer.conf) file. This binary depends heavily on
+ (or /etc/mplayer/mplayer.conf) file. This binary depends heavily on
your hardware - which means that it needs tweaking for every single
machine it's installed to. And it also it means that it will use
your setup very effectively. Look at /usr/share/doc/mplayer