summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authoreyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2002-01-05 19:35:01 +0000
committereyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2002-01-05 19:35:01 +0000
commit657b60c71b3339faff3f6fdf26d1c6ddc79442a8 (patch)
tree4bc5f5c834d5ca7817f374c0c2202f5746c61bde /debian
parent082d9e80ba2c69384e48a4bb2a08d50f72652cae (diff)
downloadmpv-657b60c71b3339faff3f6fdf26d1c6ddc79442a8.tar.bz2
mpv-657b60c71b3339faff3f6fdf26d1c6ddc79442a8.tar.xz
let people pass options to ./configure while building package.
use DEB_BUILD_OPTIONS variable for that. git-svn-id: svn://svn.mplayerhq.hu/mplayer/trunk@4001 b3059339-0415-0410-9bf9-f77b7e298cf2
Diffstat (limited to 'debian')
-rw-r--r--debian/README.debian8
-rwxr-xr-xdebian/rules2
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/README.debian b/debian/README.debian
index b0de7e6eb6..190211b2a1 100644
--- a/debian/README.debian
+++ b/debian/README.debian
@@ -7,4 +7,10 @@ mplayer for Debian
Recommended method is running "fakeroot debian/rules binary" in the top
directory
-Dariush Pietrzak <eyck@incubus.ar.lublin.pl> Wed Aug 22 21:54:12 CEST 2001
+ In case you would like to pass some parameters to ./configure, set variable
+ DEB_BUILD_OPTIONS like that:
+
+ eyck@ghost$ DEB_BUILD_OPTIONS="--enable-streaming" fakeroot debian/rules binary
+
+
+Dariush Pietrzak <eyck@ghost.anime.pl> Sat Jan 5 20:28:23 CET 2002
diff --git a/debian/rules b/debian/rules
index afacc9153a..b9e8b728c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,7 @@ configure-stamp:
dh_testdir
# Add here commands to configure the package.
$(checkdir)
- ./configure --prefix=/usr --enable-gui
+ ./configure --prefix=/usr --enable-gui $(DEB_BUILD_OPTIONS)
touch configure-stamp