summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorAnton Khirnov <wyskas@gmail.com>2009-08-08 09:45:36 +0200
committerUoti Urpala <uau@glyph.nonexistent.invalid>2009-08-23 11:08:02 +0300
commit374e168401bce73cefc2d7de75c373a46f9abc22 (patch)
tree4ecb223bc6166a2fbfecb08fbe62df51139fb36d /debian
parentd4455e4222574aadfc04dbb5222601818eef907d (diff)
downloadmpv-374e168401bce73cefc2d7de75c373a46f9abc22.tar.bz2
mpv-374e168401bce73cefc2d7de75c373a46f9abc22.tar.xz
debian/: support parallel in DEB_BUILD_OPTIONS.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 60b19808ac..fc93c22164 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,10 @@
# This is the debhelper compatability version to use.
export DH_COMPAT=4
+# do not run the actual rules of this makefile in parallel. sub-makes
+# can go in parallel
+.NOTPARALLEL:
+
package := mplayer
prefix := $(shell pwd)/debian/$(package)
@@ -14,6 +18,11 @@ arch := $(shell dpkg --print-architecture)
# https://wiki.ubuntu.com/DistCompilerFlags
CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(NUMJOBS)
+endif
+
configure: configure-stamp
configure-stamp:
dh_testdir