summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authoreyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2002-02-03 20:27:20 +0000
committereyck <eyck@b3059339-0415-0410-9bf9-f77b7e298cf2>2002-02-03 20:27:20 +0000
commit0df1b49f3d256326e47ce8fa881062021eb4e59e (patch)
tree55af2e9f2366033be3259c3ead07e8783f6c014a /debian
parenta1039fb1cd26ec03494e75e66e638ad8e24c8508 (diff)
downloadmpv-0df1b49f3d256326e47ce8fa881062021eb4e59e.tar.bz2
mpv-0df1b49f3d256326e47ce8fa881062021eb4e59e.tar.xz
Juergen Kreileder changes, fixing some lintian errors, adding correct manpath and adding
xvidix to array of system-selectable drivers. git-svn-id: svn://svn.mplayerhq.hu/mplayer/trunk@4522 b3059339-0415-0410-9bf9-f77b7e298cf2
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/config5
-rw-r--r--debian/dirs2
-rwxr-xr-xdebian/postinst2
-rwxr-xr-xdebian/rules9
4 files changed, 11 insertions, 7 deletions
diff --git a/debian/config b/debian/config
index e78546ec40..3084a67bdb 100755
--- a/debian/config
+++ b/debian/config
@@ -3,7 +3,8 @@
# Script to configure mplayer
# based on etherconf by John Goerzen <jgoerzen@progenylinux.com>
-use Debian::DebConf::Client::ConfModule qw(:all);
+use Debconf::Client::ConfModule qw(:all);
+
my $version = version(2.0);
title('MPlayer Configuration');
@@ -48,7 +49,7 @@ sub letsgo {
}
sub configure {
- subst("mplayer/voutput", "vochoices", "xv, xmga, mga, x11, gl, sdl");
+ subst("mplayer/voutput", "vochoices", "xv, xmga, mga, x11, gl, sdl, xvidix");
# db_subst mplayer/output vo xc,xmga,mga,x11,gl,sdl
exit(0) if (input($PRIORITY, "mplayer/voutput") eq "question skipped");
go();
diff --git a/debian/dirs b/debian/dirs
index e972d27203..c2d7eef0c8 100644
--- a/debian/dirs
+++ b/debian/dirs
@@ -1,4 +1,4 @@
usr/bin
-usr/sbin
usr/share/man/man1
usr/share/mplayer
+usr/lib/mplayer
diff --git a/debian/postinst b/debian/postinst
index bb9f201bfd..5653828639 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -4,7 +4,7 @@
require ConfHelper;
-use Debian::DebConf::Client::ConfModule qw(:all);
+use Debconf::Client::ConfModule qw(:all);
use IO::Handle;
use Fcntl;
my $version = version(1.0);
diff --git a/debian/rules b/debian/rules
index 28cc4ec70c..7690536e0d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,8 @@
export DH_COMPAT=3
package := mplayer
-prefix := debian/$(package)
+prefix := $(shell pwd)/debian/$(package)
+
arch := $(shell dpkg --print-architecture)
ifeq ($(arch),powerpc)
@@ -53,8 +54,10 @@ binary-arch: build
dh_installdirs
# commands to install the package into debian/<packagename>
- $(MAKE) prefix=$(prefix)/usr CONFDIR=$(prefix)/etc/mplayer DATADIR=$(prefix)/usr/share/mplayer install
- dh_link usr/bin/mplayer usr/bin/gmplayer
+ $(MAKE) prefix=$(prefix)/usr CONFDIR=$(prefix)/etc/mplayer DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
+ dh_link usr/bin/mplayer usr/bin/gmplayer \
+ usr/share/man/man1/mplayer.1.gz usr/share/man/man1/gmplayer.1.gz
+
dh_installdebconf
dh_installdocs DOCS/*