summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorarpi_esp <arpi_esp@b3059339-0415-0410-9bf9-f77b7e298cf2>2001-02-27 02:04:08 +0000
committerarpi_esp <arpi_esp@b3059339-0415-0410-9bf9-f77b7e298cf2>2001-02-27 02:04:08 +0000
commit7a098e388410617a819ecf71f602729ef8c08dc3 (patch)
treed9c00f388c9f9f92ccbbb0dc619b12d08b545f59 /debian/rules
parent0b1d7d1a17dee36e63e9b91736e13783b6d6c939 (diff)
downloadmpv-7a098e388410617a819ecf71f602729ef8c08dc3.tar.bz2
mpv-7a098e388410617a819ecf71f602729ef8c08dc3.tar.xz
Initial revision
git-svn-id: svn://svn.mplayerhq.hu/mplayer/trunk@19 b3059339-0415-0410-9bf9-f77b7e298cf2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules52
1 files changed, 52 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000000..21e4771d50
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,52 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=mplayer
+
+build:
+ $(checkdir)
+ ./setup.sh
+ ./configure --prefix=/usr `cat setup.s`
+ make dep
+ make
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -$(MAKE) distclean
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ $(MAKE) install prefix=`pwd`/debian/tmp/usr
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ debstd
+ dpkg-gencontrol -isp
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot