summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorwm4 <wm4@nowhere>2012-10-11 02:04:08 +0200
committerwm4 <wm4@nowhere>2012-10-12 10:14:32 +0200
commit65fc530f0c3ff02f982a0e4c74988d4a53730f04 (patch)
treec1faf4915a2c1e4e1d593b41a42891f0d547022f /debian/rules
parent3d712eb56da9b9dccdef28fa1a3694c4d8fccd65 (diff)
downloadmpv-65fc530f0c3ff02f982a0e4c74988d4a53730f04.tar.bz2
mpv-65fc530f0c3ff02f982a0e4c74988d4a53730f04.tar.xz
Rename to "mpv"
This changes the name of this project to mpv. Most user-visible mentions of "MPlayer" and "mplayer" are changed to "mpv". The binary name and the default config file location are changed as well. The new default config file location is: ~/.mpv/ Remove etc/mplayer.desktop. Apparently this was for the MPlayer GUI, which has been removed from mplayer2 ages ago. We don't have a logo, and the MS Windows resource files sort-of require one, so leave etc/mplayer.ico/.xpm as-is. Remove the debian and rpm packaging scripts. These contained outdated dependencies and likely were more harmful than useful. (Patches which add working and well-tested packaging are welcome.)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules108
1 files changed, 0 insertions, 108 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index d72bef3434..0000000000
--- a/debian/rules
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
-#export DH_VERBOSE=1
-
-# do not run the actual rules of this makefile in parallel. sub-makes
-# can go in parallel
-.NOTPARALLEL:
-
-package := mplayer
-prefix := $(shell pwd)/debian/$(package)
-
-arch := $(shell dpkg --print-architecture)
-
-# See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
-# https://wiki.ubuntu.com/DistCompilerFlags
-CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- MAKEFLAGS += -j$(NUMJOBS)
-endif
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
- $(checkdir)
- # If you plan to install the target .deb on a wide variety of machines,
- # you may want to add the "--enable-runtime-cpudetection" option to
- # the line below, but beware: the resulting binary will run slower
- $(CLEAN_ENV) \
- ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_CONFIGURE)
-
- touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
- dh_testdir
-
- # commands to compile the package.
- $(CLEAN_ENV) \
- ${MAKE}
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # commands to clean up after the build process.
- -$(MAKE) distclean
- dh_clean
-
-# Build architecture-independent files here.
-binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # commands to install the package into debian/<packagename>
- $(MAKE) prefix=$(prefix)/usr BINDIR=$(prefix)/usr/bin CONFDIR=$(prefix)/etc/mplayer LIBDIR=$(prefix)/usr/lib DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
-
- install -D -m 644 etc/example.conf $(prefix)/etc/mplayer/mplayer.conf
- dh_installdocs -X.svn -Xmplayer.1 DOCS/*
- dh_installexamples etc/example.conf etc/input.conf
- dh_installmime
- dh_installinfo
- dh_installchangelogs
- #ChangeLog
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-
-
-#binary-arch: checkroot build
-# $(checkdir)
-# -rm -rf debian/tmp
-# install -d debian/tmp
-# cd debian/tmp && install -d `cat ../dirs`
-
-
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
-# debstd
-# dpkg-gencontrol -isp
-# chown -R root.root debian/tmp
-# chmod -R go=rX debian/tmp
-# dpkg --build debian/tmp ..
-
-binary: binary-indep binary-arch
-
-.PHONY: binary binary-arch binary-indep clean checkroot