summaryrefslogtreecommitdiffstats
path: root/scripts/debian-update-versions
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/debian-update-versions')
-rwxr-xr-xscripts/debian-update-versions23
1 files changed, 23 insertions, 0 deletions
diff --git a/scripts/debian-update-versions b/scripts/debian-update-versions
new file mode 100755
index 0000000..af59632
--- /dev/null
+++ b/scripts/debian-update-versions
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+get_version()
+{
+ (
+ cd $1 > /dev/null
+ VERSION=1:$(git name-rev --name-only --tags HEAD | sed -e 's/^[^0-9]*//' -e 's/\^0$//')
+ if [ "$VERSION" = "1:" ]; then
+ TIMESTAMP=$(git log -1 --date=short --format=%cd | sed 's/-/./g')
+ COMMIT=$(git rev-parse --short HEAD)
+ VERSION="2:${TIMESTAMP}.${COMMIT}"
+ fi
+ echo ${VERSION}
+ )
+}
+
+do_subst() {
+ sed -e "0,/^mpv (.*)/s/(.*)/($1)/" \
+ -e "s/^ \* local build.*/ \* local build with ffmpeg $2, libass $3/" \
+ -e"s/\(^ -- Local User <localuser@localhost>\).*/\1 $(date -R)/" debian/changelog.TEMPLATE > debian/changelog
+}
+
+do_subst $(get_version mpv) $(get_version ffmpeg) $(get_version libass)