summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules7
3 files changed, 16 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 011ebdf..27e14bd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+mpv (1:0.3.4) UNRELEASED; urgency=medium
+
+ * local build
+
+ -- Local User <localuser@localhost> Tue, 04 Feb 2014 21:48:02 -0800
+
+mpv (0:0.3.4-1) stable; urgency=medium
+
+ * better changelog hack: debian build scripts read the version before
+ it gets updated. Do a sed in the ./update instead.
+
+ -- Kevin Mitchell <kevmitch@gmail.com> Tue, 04 Feb 2014 19:06:32 -0800
+
mpv (0:0.3.4) stable; urgency=medium
* changelog hack: add an "UNRELEASED" changelog entry by the
@@ -5,7 +18,7 @@ mpv (0:0.3.4) stable; urgency=medium
out mpv version. This has the "papercut" of repeating the
"local build" bullet in the same entry each time the package is built.
- -- Kevin Mitchell <kevmitch@trapezoid> Sat, 01 Feb 2014 19:09:11 -0800
+ -- Kevin Mitchell <kevmitch@gmail.com> Sat, 01 Feb 2014 19:09:11 -0800
mpv (0:0.3.3-1) stable; urgency=medium
diff --git a/debian/control b/debian/control
index 387d227..f30dc9b 100644
--- a/debian/control
+++ b/debian/control
@@ -8,9 +8,7 @@ Build-Depends:
automake,
c-compiler,
debhelper (>= 7),
- devscripts,
gcc-4.8 [powerpc powerpcspe sparc],
- git,
ladspa-sdk,
libasound2-dev [linux-any],
libbluray-dev,
diff --git a/debian/rules b/debian/rules
index 996041a..737a744 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,5 @@
#! /usr/bin/make -f
+
# from official debian package: testing welcome!
ifeq ($(DEB_HOST_ARCH_CPU),$(filter $(DEB_HOST_ARCH_CPU),powerpc sparc))
export CC=gcc-4.8 # fixes #73363
@@ -21,7 +22,7 @@ endif
# Apparently, the above isn't enough because of the "%" target. Make the problematic targets explicit
clean:
exec dh $@
-build: update_version
+build:
exec dh $@
install:
exec dh $@
@@ -31,10 +32,6 @@ install:
%:
exec dh $@
-MPV_VERSION=$(shell cd mpv && git describe --tags | sed 's/^v//';)
-update_version:
- dch -v "1:$(MPV_VERSION)" "local build"
-
# this should really create multiple shared object debian packages but
# this will do for now
# the dependencies must be built before mpv is configured