summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 06a1a0c..c7c825f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,9 @@
ifeq ($(DEB_HOST_ARCH_CPU),$(filter $(DEB_HOST_ARCH_CPU),powerpc sparc))
export CC=gcc-4.8 # fixes #73363
endif
-
+ifeq ($(DEB_HOST_ARCH_CPU),arm)
+ export CC=$(shell which gcc-4.8 || which gcc-4.7;)
+endif
# To enable parallel building:
# You can either set DEB_BUILD_OPTIONS=paralell=<num-procs> in your build environment
# or provide the -j<numprocs> option to debuild or dpkg-buildpackage, which