summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules50
1 files changed, 50 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..5b28c4b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#! /usr/bin/make -f
+
+# from official debian package: testing welcome!
+ifeq ($(DEB_HOST_ARCH_CPU),$(filter $(DEB_HOST_ARCH_CPU),powerpc sparc))
+ export CC=gcc-4.8 # fixes #73363
+endif
+
+# make .PHONY all the targets that have name collisions with the scripts
+# see http://www.debian.org/doc/manuals/maint-guide/dreq.en.html#rules
+.PHONY: clean build install
+# Apparently, the above isn't enough because of the "%" target. Make the problematic targets explicit
+clean:
+ exec dh $@ --parallel
+build:
+ exec dh $@ --parallel
+install:
+ exec dh $@ --parallel
+# handle all other targets in the usual way
+%:
+ exec dh $@ --parallel
+
+# this should really create multiple shared object debian packages but
+# this will do for now
+
+# the dependencies must be built before mpv is configured
+ffmpeg_config:
+ scripts/ffmpeg-config
+ffmpeg_build:ffmpeg_config
+ scripts/ffmpeg-build
+libass_config:
+ scripts/libass-config
+libass_build:libass_config
+ scripts/libass-build
+
+# put the config in the right place and drop the local/ since it's package managed now
+override_dh_auto_configure:ffmpeg_build libass_build
+ scripts/mpv-config --prefix=/usr --confdir=/etc/mpv
+
+override_dh_auto_build:
+ scripts/mpv-build
+
+# call waf to install to the debian packageing dir
+override_dh_auto_install:
+ (cd mpv;python ./waf -v install --destdir=../debian/mpv)
+
+#call all the cleans
+override_dh_auto_clean:
+ scripts/mpv-clean
+ scripts/ffmpeg-clean
+ scripts/libass-clean