summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 737a744..996041a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,4 @@
#! /usr/bin/make -f
-
# from official debian package: testing welcome!
ifeq ($(DEB_HOST_ARCH_CPU),$(filter $(DEB_HOST_ARCH_CPU),powerpc sparc))
export CC=gcc-4.8 # fixes #73363
@@ -22,7 +21,7 @@ endif
# Apparently, the above isn't enough because of the "%" target. Make the problematic targets explicit
clean:
exec dh $@
-build:
+build: update_version
exec dh $@
install:
exec dh $@
@@ -32,6 +31,10 @@ install:
%:
exec dh $@
+MPV_VERSION=$(shell cd mpv && git describe --tags | sed 's/^v//';)
+update_version:
+ dch -v "1:$(MPV_VERSION)" "local build"
+
# this should really create multiple shared object debian packages but
# this will do for now
# the dependencies must be built before mpv is configured