summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorKevin Mitchell <kevmitch@gmail.com>2022-08-23 20:33:00 -0700
committerKevin Mitchell <kevmitch@gmail.com>2022-08-31 23:58:40 -0700
commitd99ff36e1db62016d9344033cb3362a0e1e743e0 (patch)
treed3e6132c6a9b6f8dd40f024f6906820239989344 /debian
parentdb240a2a9b3045410ec1f47262be93222e4d0a54 (diff)
downloadmpv-build-d99ff36e1db62016d9344033cb3362a0e1e743e0.tar.bz2
mpv-build-d99ff36e1db62016d9344033cb3362a0e1e743e0.tar.xz
debian: include libplacebo in the debian package
Diffstat (limited to 'debian')
-rw-r--r--debian/control8
-rwxr-xr-xdebian/rules11
2 files changed, 16 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 6f42bed..8e4144e 100644
--- a/debian/control
+++ b/debian/control
@@ -8,6 +8,7 @@ Build-Depends:
automake,
c-compiler | gcc,
debhelper (>= 7),
+ glslang-dev,
ladspa-sdk,
libasound2-dev [linux-any],
libarchive-dev,
@@ -19,6 +20,7 @@ Build-Depends:
libdav1d-dev,
libdvdnav-dev,
libegl1-mesa-dev,
+ libepoxy-dev,
libfontconfig-dev,
libfreetype6-dev,
libfribidi-dev,
@@ -53,7 +55,9 @@ Build-Depends:
libvdpau-dev,
libvorbis-dev,
libvo-amrwbenc-dev,
+ libunwind-dev,
libvpx-dev,
+ libvulkan-dev,
libwayland-dev,
libx264-dev,
libx11-dev,
@@ -65,6 +69,8 @@ Build-Depends:
libxss-dev,
libxv-dev,
libxvidcore-dev,
+ meson,
+ ninja-build,
pkg-config,
python3,
python3-docutils,
@@ -84,5 +90,5 @@ Description: mplayer/mplayer2 based video player
MPV is a versatile CLI movie player, based on mplayer and mplayer2.
.
This package is not part of Debian. It was created by mpv-build scripts with
- statically linked ffmpeg and libass from upstream.
+ statically linked ffmpeg, libass and libplacebo from upstream.
Homepage:https://github.com/mpv-player/mpv-build
diff --git a/debian/rules b/debian/rules
index 0d642a6..d66f99c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,7 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
# use MFLAGS, rather than MAKEFLAGS as the latter is used by make internally
MFLAGS += -j$(NUMJOBS)
WAFFLAGS += -j$(NUMJOBS)
+ NINJAFLAGS += -j$(NUMJOBS)
endif
# make .PHONY all the targets that have name collisions with the scripts
@@ -36,7 +37,7 @@ libass_build: libass_config
scripts/libass-build $(MFLAGS)
# depend on libass_build in case the user specified --enable-libass in ffmpeg_options
-ffmpeg_config: libass_build
+ffmpeg_config: libass_build libplacebo_build
scripts/ffmpeg-config \
--enable-gnutls \
--enable-libdav1d \
@@ -59,8 +60,14 @@ ffmpeg_config: libass_build
ffmpeg_build: ffmpeg_config
scripts/ffmpeg-build $(MFLAGS)
+libplacebo_config:
+ scripts/libplacebo-config
+
+libplacebo_build: libplacebo_config
+ scripts/libplacebo-build $(NINJAFLAGS)
+
# put the config in the right place and drop the local/ since it's package managed now
-override_dh_auto_configure: ffmpeg_build libass_build
+override_dh_auto_configure: ffmpeg_build libass_build libplacebo_build
scripts/mpv-config --prefix=/usr --confdir=/etc/mpv \
--enable-openal \
--enable-dvdnav \