summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorKevin Mitchell <kevmitch@gmail.com>2023-01-23 00:48:54 -0800
committerKevin Mitchell <kevmitch@gmail.com>2023-01-23 21:53:48 -0800
commit7b34395fa4b4136adbac39189db7b04a90089b0e (patch)
tree8d13a1b8d15970ab790e15d23101fe7830bc5928 /debian
parent1779b9c4c2d8a493c374d42e3ae7ecaaa43f3347 (diff)
downloadmpv-build-7b34395fa4b4136adbac39189db7b04a90089b0e.tar.bz2
mpv-build-7b34395fa4b4136adbac39189db7b04a90089b0e.tar.xz
debian: adapt to mpv meson switch
The options passed through mpv-config have different syntax. --confdir is no longer necessary. Rename $WAFFLAGS to $MESONFLAGS. Use the mpv-install script with appropriate --destdir. Remove the unused DOCS and TOOLS variables.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules24
1 files changed, 10 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index d66f99c..312b37b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,7 +10,7 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
# use MFLAGS, rather than MAKEFLAGS as the latter is used by make internally
MFLAGS += -j$(NUMJOBS)
- WAFFLAGS += -j$(NUMJOBS)
+ MESONFLAGS += -j$(NUMJOBS)
NINJAFLAGS += -j$(NUMJOBS)
endif
@@ -66,24 +66,20 @@ libplacebo_config:
libplacebo_build: libplacebo_config
scripts/libplacebo-build $(NINJAFLAGS)
-# put the config in the right place and drop the local/ since it's package managed now
+# drop the local/ since it's package managed now
override_dh_auto_configure: ffmpeg_build libass_build libplacebo_build
- scripts/mpv-config --prefix=/usr --confdir=/etc/mpv \
- --enable-openal \
- --enable-dvdnav \
- --enable-cdda
+ scripts/mpv-config --prefix=/usr \
+ -Dopenal=enabled \
+ -Ddvdnav=enabled \
+ -Dcdda=enabled
override_dh_auto_build:
- scripts/mpv-build $(WAFLAGS)
+ scripts/mpv-build $(MESONFLAGS)
-
-DOCSOURCE=mpv/DOCS
-TOOLSSOURCE=mpv/TOOLS
-DOCDEST=debian/mpv/usr/share/doc/mpv
-TOOLSDEST=$(DOCDEST)/TOOLS
-# call waf to install to the debian packageing dir
+# install mpv to the debian packageing dir
+# --destdir is relative to mpv/build
override_dh_auto_install:
- cd mpv && python3 waf -v install --destdir=../debian/mpv
+ scripts/mpv-install --destdir=../../debian/mpv
# for manually installed dependencies
override_dh_shlibdeps: