summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorKevin Mitchell <kevmitch@gmail.com>2015-11-22 02:24:38 -0800
committerKevin Mitchell <kevmitch@gmail.com>2015-11-22 21:27:14 -0800
commit56d4afc0069170c8e6e23491cb1068c92d39aac3 (patch)
tree9f36debd52443939ed5b18118aab90c803d03708 /debian
parentb202a5fdaf1205fa2e626d64aa1a3d1a04dfe581 (diff)
downloadmpv-build-56d4afc0069170c8e6e23491cb1068c92d39aac3.tar.bz2
mpv-build-56d4afc0069170c8e6e23491cb1068c92d39aac3.tar.xz
debian: enable modplug and openal
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 0882dd8..660d9c8 100644
--- a/debian/control
+++ b/debian/control
@@ -33,7 +33,9 @@ Build-Depends:
liblcms2-dev,
liblircclient-dev,
liblua5.2-dev | liblua5.1-0-dev,
+ libmodplug-dev,
libmp3lame-dev,
+ libopenal-dev,
libopus-dev,
libopencore-amrnb-dev,
libopencore-amrwb-dev,
diff --git a/debian/rules b/debian/rules
index 163a3ed..ac0b1b1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,6 +41,7 @@ ffmpeg_config: libass_build
--enable-gnutls \
--enable-libgme \
--enable-libgsm \
+ --enable-libmodplug \
--enable-libmp3lame \
--enable-libopenjpeg \
--enable-libopus \
@@ -64,7 +65,7 @@ ffmpeg_build: ffmpeg_config
# put the config in the right place and drop the local/ since it's package managed now
override_dh_auto_configure: ffmpeg_build libass_build
- scripts/mpv-config --prefix=/usr --confdir=/etc/mpv --enable-egl-x11
+ scripts/mpv-config --prefix=/usr --confdir=/etc/mpv --enable-egl-x11 --enable-openal
override_dh_auto_build:
scripts/mpv-build $(WAFLAGS)