summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2009-09-01 23:15:48 +0200
committerGrigori Goronzy <greg@blackbox>2009-09-01 23:21:24 +0200
commitcf7c6e4cc8cd8cec37041179239554905a4a7517 (patch)
treeb27b420d8c66bf7ac02c94a5cccee657b14de0ec /libass/Makefile.am
parenta854a325a2586ee1d947493036b188acadbaaef2 (diff)
downloadlibass-cf7c6e4cc8cd8cec37041179239554905a4a7517.tar.bz2
libass-cf7c6e4cc8cd8cec37041179239554905a4a7517.tar.xz
Refactor: move event parsing code into separate file
Move all code related to parsing event lines and processing override tags into a separate file (ass_parse.c).
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index 28c99ae..0cf613e 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -7,7 +7,8 @@ libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontconfig.c ass_render.c \
ass_utils.c ass_bitmap.c ass_library.c ass_bitmap.h \
ass_cache.h ass_fontconfig.h ass_font.h ass.h \
ass_library.h ass_types.h ass_utils.h ass_drawing.c \
- ass_drawing.h ass_cache_template.h ass_render.h
+ ass_drawing.h ass_cache_template.h ass_render.h \
+ ass_parse.c ass_parse.h
libass_la_LDFLAGS = -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym