summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2021-08-27 17:19:21 +0200
committerOneric <oneric@oneric.stub>2021-09-15 03:00:11 +0200
commit6409945b1c9bb626cca5a5303a7cac16429c5a47 (patch)
tree50140d0f3d38c9f1856904d6aad33a918bce377e /libass/Makefile.am
parent88255b06dcf99ca37ae2493c1618dafb84837b2f (diff)
downloadlibass-6409945b1c9bb626cca5a5303a7cac16429c5a47.tar.bz2
libass-6409945b1c9bb626cca5a5303a7cac16429c5a47.tar.xz
Use a wrapper script for NASM
libtool assumes NASM accepts the same flags as the C-compiler, which is not actually the case. Previously we used -prefer-no-pic to avoid any additional flags being appended by libtool, which worked well for all tested platforms, but as it turns out it doesn't for NetBSD and OpenBSD. Using this wrapper-script also enables us to automatically define the PIC macro as needed, which became relevant when we started supporting 32-bit x86 PIC-assembly in 026d65e707637b0f90902bca48654871e33575f3.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index d84012c..894c91c 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -12,7 +12,7 @@ nasm_verbose_ = $(nasm_verbose_$(AM_DEFAULT_VERBOSITY))
nasm_verbose_0 = @echo " NASM " $@;
.asm.lo:
- $(nasm_verbose)$(LIBTOOL) $(AM_V_lt) --tag=CC --mode=compile $(AS) $(ASFLAGS) -I$(srcdir)/ -o $@ $< -prefer-non-pic
+ $(nasm_verbose)$(LIBTOOL) $(AM_V_lt) --tag=CC --mode=compile $(top_srcdir)/ltnasm.sh $(AS) $(ASFLAGS) -I$(srcdir)/ -o $@ $<
SRC_INTEL = x86/rasterizer.asm x86/blend_bitmaps.asm x86/be_blur.asm x86/blur.asm x86/cpuid.asm \
x86/cpuid.h