summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@chown.ath.cx>2015-09-07 23:44:41 +0200
committerGrigori Goronzy <greg@chown.ath.cx>2015-09-11 01:12:47 +0200
commit47c79b79d57d017d590e9423cf1a93ed6bdfad38 (patch)
tree030579ca5e133ef3a896755ef8bcea51e91cc401 /libass/Makefile.am
parent448bc77c909009e5a75cf93f41fcfce0ebedd7eb (diff)
downloadlibass-47c79b79d57d017d590e9423cf1a93ed6bdfad38.tar.bz2
libass-47c79b79d57d017d590e9423cf1a93ed6bdfad38.tar.xz
NIH: add locale-independent string functions
OS or platform-specific locale independent functions are painful to use and/or not available, so roll our own. Not great but the least painful and least intrusive. v2: fix indexing, use static inline
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index 2cf6354..cef1291 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -29,7 +29,8 @@ libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontselect.c ass_render.c \
ass_library.h ass_types.h ass_utils.h ass_drawing.c \
ass_drawing.h ass_cache_template.h ass_render.h \
ass_parse.c ass_parse.h ass_render_api.c ass_shaper.c \
- ass_shaper.h ass_strtod.c ass_fontconfig.c ass_fontconfig.h
+ ass_shaper.h ass_strtod.c ass_fontconfig.c ass_fontconfig.h \
+ ass_string.h ass_string.c
libass_la_LDFLAGS = -no-undefined -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym