summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorDr.Smile <vabnick@gmail.com>2021-03-09 04:35:20 +0300
committerDr.Smile <vabnick@gmail.com>2021-04-21 21:46:00 +0300
commit10160c4eddd3c1a4e340a193dde8f188c13d3a04 (patch)
tree25686237b46c8a10733575fbf079bf7c8b885265 /libass/Makefile.am
parentccc646de63f1e9e5594c991e04618240e81902bd (diff)
downloadlibass-10160c4eddd3c1a4e340a193dde8f188c13d3a04.tar.bz2
libass-10160c4eddd3c1a4e340a193dde8f188c13d3a04.tar.xz
Rewrite be_blur() assembly
Change list: - Fixed differences from C version introduced in f23b9ed64bd4ccf249c686616dd3f51a69d285dc. - Common macro for SSE2 and AVX2 versions. - Reduced register usage and efficient 32-bit version. - Full width memory operations instead of half-register. - Vectorized handling of width tails instead of byte/word loops. - Vectorized initial population of temporary buffer and final line fill. - Interleaved layout of temporary buffer. - Great speedup overall.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index ac3c545..f0e14ff 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -14,9 +14,8 @@ nasm_verbose_0 = @echo " NASM " $@;
.asm.lo:
$(nasm_verbose)$(LIBTOOL) $(AM_V_lt) --tag=CC --mode=compile $(AS) $(ASFLAGS) -I$(srcdir)/ -o $@ $< -prefer-non-pic
-SRC_INTEL = x86/rasterizer.asm x86/blend_bitmaps.asm x86/blur.asm x86/cpuid.asm \
+SRC_INTEL = x86/rasterizer.asm x86/blend_bitmaps.asm x86/be_blur.asm x86/blur.asm x86/cpuid.asm \
x86/cpuid.h
-SRC_INTEL64 = x86/be_blur.asm
SRC_FONTCONFIG = ass_fontconfig.c ass_fontconfig.h
SRC_DIRECTWRITE = ass_directwrite.c ass_directwrite.h dwrite_c.h
@@ -51,9 +50,6 @@ endif
if ASM
if INTEL
libass_la_SOURCES += $(SRC_INTEL)
-if X64
-libass_la_SOURCES += $(SRC_INTEL64)
-endif
endif
endif