summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOleg Oshmyan <chortos@inbox.lv>2022-02-12 19:44:43 +0200
committerOleg Oshmyan <chortos@inbox.lv>2022-02-12 19:44:43 +0200
commitc4e2aadc88db638eed6090fa81a690235a11d3bd (patch)
treefbee5b3b45e9daef6c72b203c5f3b7bd69cd2c3f /configure.ac
parentfe296cb5930d12b323237089bd2da42de1790ae0 (diff)
downloadlibass-c4e2aadc88db638eed6090fa81a690235a11d3bd.tar.bz2
libass-c4e2aadc88db638eed6090fa81a690235a11d3bd.tar.xz
Consistently use x86 asm code if we've built it
We detect x86 and enable building asm code in `configure`. However, before this commit, we don't actually use that code unless we detect x86 via the C compiler's predefined macros. We could check more macros to support more C compilers, but what we really want is to use the same trigger for both building and using this code. To that end, add ARCH_X86 to config.h iff x86 asm is being built.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7186578..d97cb98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,6 +322,9 @@ AM_CONDITIONAL([DIRECTWRITE], [test "x$directwrite" = xtrue])
## Define C Macros not relating to libraries
AM_COND_IF([ASM], [
AC_DEFINE(CONFIG_ASM, 1, [ASM enabled])
+ AM_COND_IF([X86], [
+ AC_DEFINE(ARCH_X86, 1, [targeting a 32- or 64-bit x86 host architecture])
+ ])
], [
AC_DEFINE(CONFIG_ASM, 0, [ASM enabled])
])