summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorwm4 <wm4@nowhere>2015-07-11 19:33:44 +0200
committerwm4 <wm4@nowhere>2015-07-11 23:09:54 +0200
commitab9b9cf254a7871f4f8cdee386971f0ba5c58e13 (patch)
tree8b86907d86162df88700843f7167ad1163b68a05 /configure.ac
parent109254ab11a2f49d4c25a59c08156647719faf4f (diff)
downloadlibass-ab9b9cf254a7871f4f8cdee386971f0ba5c58e13.tar.bz2
libass-ab9b9cf254a7871f4f8cdee386971f0ba5c58e13.tar.xz
directwrite: dynamically load dwrite.dll
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 26c2c37..61a8533 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,20 +180,17 @@ fi
if test x$enable_directwrite != xno; then
AC_LANG_PUSH([C++])
CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
-OLDLIBS="$LIBS"
# Linking to DirectWrite directly only works from Windows
-LIBS="$LIBS -ldwrite"
AC_MSG_CHECKING([for DIRECTWRITE])
AC_LINK_IFELSE([
AC_LANG_PROGRAM(
[[#include <dwrite.h>]],
- [[DWriteCreateFactory(DWRITE_FACTORY_TYPE_SHARED, __uuidof(IDWriteFactory), NULL);]],)
+ [[DWRITE_FACTORY_TYPE_SHARED;]],)
], [
AC_DEFINE(CONFIG_DIRECTWRITE, 1, [found DirectWrite])
directwrite=true
AC_MSG_RESULT([yes])
], [
- LIBS="$OLDLIBS"
directwrite=false
AC_MSG_RESULT([no])
])