summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2023-01-01 15:51:36 +0100
committerOneric <oneric@oneric.stub>2023-01-01 15:51:37 +0100
commita943ef542e72e849dc0c1047465e0506781374b5 (patch)
tree18ab3d503a908e74d87a922328d2373591ef5a8d /configure.ac
parent062d4ec598b4fd06f75c0cd6a0f43f5d0939a764 (diff)
downloadlibass-a943ef542e72e849dc0c1047465e0506781374b5.tar.bz2
libass-a943ef542e72e849dc0c1047465e0506781374b5.tar.xz
configure: support x86 assembly on GNU Hurd
Hurd too uses ELF and 16-byte stack alignment just like Linux and many other Unix-likes. Supposedly its host triplet can include a version number at the end. Without getting more specific about how a version number is allowed to look like, checking for *-gnu* overlaps with X32's -gnux32 suffix which is present on non-Hurd systems. Linux is the only X32 platform I know about and it uses an identical configuration to GNU Hurd, so this shouldn't be a problem. Though to be safe, let's move the case with *-gnu* at the end, to ensure if there's a "-gnux32"-like suffix on any non-Linux, non-Hurd system it will match the proper host regex before seeing Hurd's *-gnu* pattern. Thanks to youpi1 for advice about Hurd and testing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 83a8c4f..d2b1fdc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,9 +279,6 @@ AS_IF([test "x$enable_asm" != xno], [
[*darwin*], [
ASFLAGS="$ASFLAGS -f macho$BITTYPE -DPREFIX -DSTACK_ALIGNMENT=16"
],
- [*linux*|*solaris*|*haiku*], [
- ASFLAGS="$ASFLAGS -f elf$BITTYPE -DSTACK_ALIGNMENT=16"
- ],
[*dragonfly*|*bsd*], [
ASFLAGS="$ASFLAGS -f elf$BITTYPE"
],
@@ -291,6 +288,9 @@ AS_IF([test "x$enable_asm" != xno], [
ASFLAGS="$ASFLAGS -DPREFIX"
])
],
+ [*linux*|*solaris*|*haiku*|*-gnu*], [
+ ASFLAGS="$ASFLAGS -f elf$BITTYPE -DSTACK_ALIGNMENT=16"
+ ],
[ # default
AC_MSG_ERROR(m4_text_wrap(m4_normalize([
Please contact libass upstream to figure out if ASM