summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2022-05-13 21:41:15 +0200
committerOneric <oneric@oneric.stub>2022-07-29 17:51:57 +0200
commit52004898e16c7b33217bb1363aaac65f3d397ba5 (patch)
treece6b7c9a189a3027fe1acc1d5fae85ed33390f72 /configure.ac
parenta28e2c1390df7f9b3069650bd60de26077074f97 (diff)
downloadlibass-52004898e16c7b33217bb1363aaac65f3d397ba5.tar.bz2
libass-52004898e16c7b33217bb1363aaac65f3d397ba5.tar.xz
make: integrate regression tests
Use `-j 1` in CI for unmangled output. In the future this could be improved by integrating with Automake's test support to get better output with multiple jobs. Considering the layour of the crash tests will likely change and that currently the tests run in less 15 seconds even with just a single thread, this should be good enough for now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f87f855..42b5a81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,8 @@ AC_ARG_ENABLE([asm], AS_HELP_STRING([--disable-asm],
AC_ARG_ENABLE([large-tiles], AS_HELP_STRING([--enable-large-tiles],
[use larger tiles in the rasterizer (better performance, slightly worse quality) @<:@default=disabled@:>@]))
+AC_ARG_VAR([ART_SAMPLES],
+ [Path to the root of libass' regression testing sample repository. If set, it is used in make check.])
AC_ARG_VAR([FUZZ_LDFLAGS],
[Optional special linking flags only used for the fuzzer binary.])
AC_ARG_VAR([FUZZ_CPPFLAGS],