summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2021-10-10 23:43:51 +0200
committerOneric <oneric@oneric.stub>2021-10-11 00:06:46 +0200
commit3329d91239ee6213995867e143f345e0771b38f1 (patch)
tree52a706f2230ebbb9d467e70bd145727f343f7272 /configure.ac
parent7bf4bee0fc9a1d6257a105a3c19df6cf08733f8e (diff)
downloadlibass-3329d91239ee6213995867e143f345e0771b38f1.tar.bz2
libass-3329d91239ee6213995867e143f345e0771b38f1.tar.xz
configure: use AC_PACKAGE_VERSION
AC_INIT already defines a macro for the version so there's no need to create our own.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6ae78a1..71e4a57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,4 @@
-m4_define([LIBASS_VERSION], [0.15.2])
-AC_INIT(libass, LIBASS_VERSION)
+AC_INIT(libass, 0.15.2)
AM_INIT_AUTOMAKE([foreign])
AC_CONFIG_MACRO_DIR([m4])
# Disable Fortran checks
@@ -342,11 +341,11 @@ AS_IF([test -e "${srcdir}/.git"], [
AS_IF([test -n "$git_bin"], [
srcversion_string="commit: $("$git_bin" -C "$srcdir" describe --tags --long --always --dirty --broken --abbrev=40)"
], [
- srcversion_string="custom after: LIBASS_VERSION"
+ srcversion_string="custom after: AC_PACKAGE_VERSION"
])
], [
dnl# Hope no one creates custom tarballs without adjusting the version
- srcversion_string="tarball: LIBASS_VERSION"
+ srcversion_string="tarball: AC_PACKAGE_VERSION"
])
AC_DEFINE_UNQUOTED([CONFIG_SOURCEVERSION], ["$srcversion_string"],
[string containing info about the used source])