summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorwm4 <wm4@nowhere>2015-08-28 15:39:32 +0200
committerwm4 <wm4@nowhere>2015-08-28 15:42:32 +0200
commit22d100831e59eeb572d316bf110f5ead8cfe9a2f (patch)
tree66df6ed8146ef0a02d3c106de8a03c241a602964 /configure.ac
parentcde3b40bce6b544d9f4a9fa695f316bae5aaa84f (diff)
downloadlibass-22d100831e59eeb572d316bf110f5ead8cfe9a2f.tar.bz2
libass-22d100831e59eeb572d316bf110f5ead8cfe9a2f.tar.xz
configure: proper configure switches for DirectWrite and CoreText
Also, remove the ass_coretext.c conditional compilation hack, and fix Makefile.am instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3538b9..ba0f5e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,10 @@ AC_ARG_ENABLE([enca], AS_HELP_STRING([--disable-enca],
[disable enca (charset autodetect) support @<:@default=check@:>@]))
AC_ARG_ENABLE([fontconfig], AS_HELP_STRING([--disable-fontconfig],
[disable fontconfig support @<:@default=enabled@:>@]))
+AC_ARG_ENABLE([directwrite], AS_HELP_STRING([--disable-directwrite],
+ [disable DirectWrite support (win32 only) @<:@default=check@:>@]))
+AC_ARG_ENABLE([coretext], AS_HELP_STRING([--disable-coretext],
+ [disable CoreText support (OSX only) @<:@default=check@:>@]))
AC_ARG_ENABLE([harfbuzz], AS_HELP_STRING([--disable-harfbuzz],
[disable HarfBuzz support @<:@default=check@:>@]))
AC_ARG_ENABLE([asm], AS_HELP_STRING([--disable-asm],
@@ -165,6 +169,7 @@ AC_LINK_IFELSE([
AC_MSG_RESULT([no])
])
fi
+AM_CONDITIONAL([CORETEXT], [test x$coretext = xtrue])