summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2022-04-04 23:41:23 +0200
committerOneric <oneric@oneric.stub>2022-05-12 21:13:00 +0200
commita2b39cde4ecb74d5e6fccab4a5f7d8ad52b2b1a4 (patch)
treef72dab3f4477d684ccb0839ed07aaf141f7f9eb6 /Makefile.am
parent1af6240c5d1e499326146e0b88c987e626b13c23 (diff)
downloadlibass-a2b39cde4ecb74d5e6fccab4a5f7d8ad52b2b1a4.tar.bz2
libass-a2b39cde4ecb74d5e6fccab4a5f7d8ad52b2b1a4.tar.xz
Switch to non-recursive Makefile
Non-recursive Makefiles allow better and more robust automatic dependency resolution and higher parallelism for shorter build-times. This change keeps all locations of the non-installed targets unchanged for minimal firction. Calling make from subdirectories no longer works, but instead the specific build targets can be invoked directly from the toplevel. If we bumped the required Automake version to 1.13+, the library fragment could use %reldir% or %D% to be unaffected by potential future directory moves, but it is unlikely we'll ever change the location or name of the libass directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 3506e98..0c1a5b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,20 +1,16 @@
ACLOCAL_AMFLAGS = -I m4
+AM_CFLAGS = -std=gnu99 -Wall -Wextra -Wno-sign-compare -Wno-unused-parameter \
+ -Werror-implicit-function-declaration -Wstrict-prototypes \
+ -Wpointer-arith -Wredundant-decls -Wno-missing-field-initializers\
+ -D_GNU_SOURCE
+
EXTRA_DIST = libass.pc.in Changelog MAINTAINERS ltnasm.sh
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libass.pc
-if ENABLE_TEST
- test = test
-endif
-
-if ENABLE_COMPARE
- compare = compare
-endif
-
-if ENABLE_PROFILE
- profile = profile
-endif
-
-SUBDIRS = libass $(test) $(compare) $(profile)
+lib_LTLIBRARIES =
+noinst_PROGRAMS =
+include libass/Makefile_library.am
+include Makefile_util.am