summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorOneric <oneric@oneric.stub>2022-05-13 21:41:15 +0200
committerOneric <oneric@oneric.stub>2022-07-29 17:51:57 +0200
commit52004898e16c7b33217bb1363aaac65f3d397ba5 (patch)
treece6b7c9a189a3027fe1acc1d5fae85ed33390f72 /Makefile.am
parenta28e2c1390df7f9b3069650bd60de26077074f97 (diff)
downloadlibass-52004898e16c7b33217bb1363aaac65f3d397ba5.tar.bz2
libass-52004898e16c7b33217bb1363aaac65f3d397ba5.tar.xz
make: integrate regression tests
Use `-j 1` in CI for unmangled output. In the future this could be improved by integrating with Automake's test support to get better output with multiple jobs. Considering the layour of the crash tests will likely change and that currently the tests run in less 15 seconds even with just a single thread, this should be good enough for now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c1a5b4..d814e86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,3 +14,28 @@ noinst_PROGRAMS =
include libass/Makefile_library.am
include Makefile_util.am
+
+# Tests
+if ENABLE_FUZZ
+check: check-art-fuzz
+.PHONY: check-art-fuzz
+check-art-fuzz: fuzz/fuzz
+ @if [ -z '$(ART_SAMPLES)' ] ; then \
+ echo "ART_SAMPLES location not set; cannot run regression tests!"; \
+ else \
+ cd '$(ART_SAMPLES)'/crash/ ; \
+ ./run-all.sh '$(abs_top_builddir)'/fuzz/fuzz ; \
+ fi
+endif
+
+if ENABLE_COMPARE
+check: check-art-compare
+.PHONY: check-art-compare
+check-art-compare: compare/compare
+ @if [ -z '$(ART_SAMPLES)' ] ; then \
+ echo "ART_SAMPLES location not set; cannot run regression tests!"; \
+ else \
+ cd '$(ART_SAMPLES)'/regression/ ; \
+ ./run-all.sh '$(abs_top_builddir)'/compare/compare ; \
+ fi
+endif