summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDr.Smile <vabnick@gmail.com>2019-05-27 00:50:04 +0300
committerDr.Smile <vabnick@gmail.com>2020-05-07 18:36:35 +0300
commit46f44957e54cdd6d0c3554ad44bae5eb17ad74fc (patch)
tree33c7982d758a8e6b24ab8839a71fa3f646348590 /Makefile.am
parente5140624ff739c3157929bc5e1a1007cdc9cdaa8 (diff)
downloadlibass-46f44957e54cdd6d0c3554ad44bae5eb17ad74fc.tar.bz2
libass-46f44957e54cdd6d0c3554ad44bae5eb17ad74fc.tar.xz
Add infrastructure for regression testing
`test` subdirectory contains complete test example.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4cd26e6..7f72ed7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,13 +5,17 @@ EXTRA_DIST = libass.pc.in Changelog
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libass.pc
-if HAVE_LIBPNG
+if ENABLE_TEST
test = test
endif
+if ENABLE_COMPARE
+ compare = compare
+endif
+
if ENABLE_PROFILE
profile = profile
endif
-SUBDIRS = libass $(test) $(profile)
+SUBDIRS = libass $(test) $(compare) $(profile)