summaryrefslogtreecommitdiffstats
path: root/DOCS/man/en
Commit message (Collapse)AuthorAgeFilesLines
* DOCS: remove en/ sub-directorywm42014-06-2011-8966/+0
| | | | | This additional sub-directory doesn't serve any purpose anymore. Get rid of it.
* manpage: explicitly document protocolswm42014-06-201-12/+79
|
* manpage: remove some trailing whitespacewm42014-06-201-1/+1
| | | | I wish I could make github run a hook to reject these.
* manpage: remove bogus significant whitespacewm42014-06-181-1/+1
| | | | Made the first line formatted differently.
* options: allow adding multiple files with --audio-filewm42014-06-181-2/+3
| | | | At least 1 person expected that this works this way.
* sub: add --sub-scale-with-window optionwm42014-06-141-0/+8
| | | | Implements the feature requested in #839 and #186.
* options: turn --idx, --forceidx into --indexwm42014-06-132-14/+9
| | | | | | | | | | | | Also clarify the semantics. It seems --idx didn't do anything. Possibly it used to change how the now removed legacy demuxers like demux_avi used to behave. Or maybe it was accidental. --forceidx basically becomes --index=force. It's possible that new index modes will be added in the future, so I'm keeping it extensible, instead of e.g. creating --force-index.
* input: make option struct localwm42014-06-111-11/+11
| | | | | | | | | Similar to previous commits. This also renames --doubleclick-time to --input-doubleclick-time, and --key-fifo-size to --input-key-fifo-size. We could keep the old names, but these options are very obscure, and renaming them seems better for consistency.
* options: remove global variables for swscale options; rename themwm42014-06-112-30/+21
| | | | | | Additionally to removing the global variables, this makes the options more uniform. --ssf-... becomes --sws-..., and --sws becomes --sws- scaler. For --sws-scaler, use choices instead of magic integer values.
* stream_dvb: remove global option variableswm42014-06-111-12/+11
|
* stream_cdda: remove global option variableswm42014-06-111-28/+23
|
* stream_pvr: remove global option variableswm42014-06-111-36/+35
|
* tv: remove global option variableswm42014-06-111-136/+128
| | | | | | Pretty much nothing changes, but using -tv-scan with suboptions doesn't work anymore (instead of "-tv-scan x" it's "-tv scan-x" now). Flat options ("-tv-scan-x") stay compatible.
* command: redo ancient TV/DVB/PVR commandswm42014-06-112-5/+28
| | | | | | | | | | | | | | | | | | Convert all these commands to properties. (Except tv_last_channel, not sure what to do with this.) Also, internally, don't access stream details directly, but dispatch commands with stream ctrls. Many of the new properties are a bit strange, because they're write- only. Also remove some OSD output these commands produced, because I couldn't be bothered to port these. In general, this makes everything much cleaner, and will also make it easier to e.g. move the demuxer to its own thread. Don't bother updating input.conf, but changes.rst documents how old commands map to the new ones. Mostly untested, due to lack of hardware.
* audio: add a "weak" gapless mode, and make it defaultwm42014-06-091-16/+27
| | | | | | | | | | | | | | Basically, this allows gapless playback with similar files (including the ordered chapter case), while still being robust in general. The implementation is quite simplistic on purpose, in order to avoid all the weird corner cases that can occur when creating the filter chain. The consequence is that it might do not-gapless playback in more cases when needed, but if that bothers you, you still can use the normal gapless mode. Just using "--gapless-audio" or "--gapless-audio=yes" selects the old mode.
* manpage: document new --sub-file semanticswm42014-06-081-3/+11
| | | | This was forgotten in the previous commit.
* sub: remove old style override optionwm42014-06-051-6/+1
| | | | Didn't work too well.
* sub: add --ass-style-override=force optionwm42014-06-051-3/+10
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | (The old "force" choice of that option is renamed to "force-default".) This allows overriding native ASS script subtitle styles with the style provided by the --sub-text-* options (like --sub-text-font etc.). This is disabled by default, and needs to be explicitly enabled with the --ass-style-override=force option and input property. This uses in fact exactly the same options (--sub-text-*) and semantics as the ones used to configure unstyled text subtitles. It's recommended to combine this with this in the mpv config file: ass-force-style="ScaledBorderAndShadow=1" # work around dumb libass behavior Also, adding a key binding to toggle this behavior should be added, because overriding can easily break: L cycle ass-style-override This would cycle override behavior on Shift+L and allows quickly disabling/enabling style overrides. Note: ASS should be considered a vector format rather than a subtitle format. There is no easy or reliable way to determine whether the style of a given subtitle event can be changed without destroying visuals or not. This patch relies on a simple heuristic, which often works and often breaks.
* player: write file name to the watch later config fileAlessandro Ghedini2014-06-011-0/+9
| | | | | | | | | This simply writes the file name as a comment to the top of the watch later config file. It can be useful to the user for determining whether a watch later config file can be manually removed (e.g. in case the corresponding media file has been deleted) or not.
* stream: remove VCD supportwm42014-06-011-1/+0
| | | | | | | | | If a single person complains, I will readd it. But I don't expect that this will happen. The main reason for removing this is that it's some of the most unclean code remaining, it's unmaintained, and I've never ever heard of someone using it.
* ao_alsa: make device the first sub optionwm42014-05-311-3/+3
| | | | This is more convenient.
* manpage: document write_watch_later_config commandwm42014-05-271-0/+3
|
* lua: fix compilation with lua 5.2wm42014-05-261-1/+1
| | | | | | | | | | | Commit e2e450f9 started making use of luaL_register(), but OF COURSE this function disappeared in Lua 5.2, and was replaced with a 5.2-only alternative, slightly different mechanism. So just NIH our own function. This is actually slightly more correct, since it forces the user to call "require" to actually make the module visible for builtin C-only modules other than "mp". Fix autoload.lua accordingly.
* command: add write_watch_later_config commandMartin2014-05-261-0/+3
| | | | | | Closes #808. Signed-off-by: wm4 <wm4@nowhere>
* lua: add some filesystem utility functionswm42014-05-251-0/+42
| | | | | | | | | | | We need this only because Lua's stdlib is so scarce. Lua doesn't intend to include a complete stdlib - they confine themselves to standard C, both for portability reasons and to keep the code minimal. But standard C does not provide much either. It would be possible to use Lua POSIX wrapper libraries, but that would be a messy (and unobvious) dependency. It's better to implement the missing functions ourselves, as long as they're small in number.
* manpage: lua: cosmetic changes to mp.options sectionwm42014-05-251-4/+4
|
* osc: fix chapter list displayChrisK22014-05-241-2/+2
| | | | also fix small typo in DOCS
* video: add --video-rotate option for controlling auto-rotationwm42014-05-241-0/+7
|
* stream: kill start_pos, remove --sb optionwm42014-05-242-8/+1
| | | | | | | | | | | | | | | | | | | | stream.start_pos was needed for optical media only, and (apparently) not for very good reasons. Just get rid of it. For stream_dvd, we don't need to do anything. Byte seeking was already removed from it earlier. For stream_cdda and stream_vcd, emulate the start_pos by offsetting the stream pos as seen by the rest of mpv. The bits in discnav.c and loadfile.c were for dealing with the code seeking back to the start in demux.c. Handle this differently by assuming the demuxer is always initialized with the stream at start position, and instead seek back if initializing the demuxer fails. Remove the --sb option, which worked by modifying stream.start_pos. If someone really wants this option, it could be added back by creating a "slice" stream (actually ffmpeg already has such a thing).
* manpage: update references to renamed optionsAlessandro Ghedini2014-05-234-9/+9
|
* lua/osc: forgot some changed files in previous commitChrisK22014-05-232-20/+94
|
* player: give quit_watch_later an exit code argument like quitwm42014-05-221-3/+4
| | | | | | | | The quit command has an optional argument that is used as exit code. Extend that to the quit_watch_later command. Actually, unify the implementations of the two commands. Requested in #798.
* input: allow disabling window dragging with --no-window-draggingwm42014-05-201-0/+3
| | | | Requested in github issue #608.
* manpage: mention bdnav://wm42014-05-201-2/+2
|
* cache: redo options and default settingswm42014-05-202-16/+17
| | | | | | | | | | | | Some options change from percentages to number of kilobytes; there are no cache options using percentages anymore. Raise the default values. The cache is now 25000 kilobytes, although if your connection is slow enough, the maximum is probably never reached. (Although all the memory will still be used as seekback-cache.) Remove the separate --audio-file-cache option, and use the cache default settings for it.
* etc/input.conf: add example how to change window size by key bindingwm42014-05-181-0/+2
| | | | Also drop a vague hint how to do it in the manpage.
* manpage: fix a minor aspect of the discnav commandwm42014-05-181-2/+1
| | | | | "menu" is in fact understood by stream_bluray.c, so just drop that sentence.
* manpage: document discnav commandwm42014-05-181-0/+14
|
* command: add a disc-menu-active propertywm42014-05-181-0/+6
| | | | Returns whether a DVD/BD menu is active. As requested by #788.
* x11: implement --fs-screen properly, separate old code pathwm42014-05-171-4/+2
| | | | | | | Try to get the "new" code path (using NetWM/EWMH) free of hacks done for the sake of old WMs or the no-WM case. Implement --fs-screen using _NET_WM_FULLSCREEN_MONITORS.
* x11: replace--[x11-]fstype option with --x11-netwmwm42014-05-162-39/+13
| | | | | Simplifies the code a lot. You can still use --x11-netwm=no to disable NetWM for whatever reasons.
* manpage: changes.rst: minor fixupswm42014-05-151-5/+5
|
* vf_vapoursynth: allow parallel processingwm42014-05-141-8/+20
| | | | | | | | VapourSynth won't just filter multiple frames at once on its own. You have to request multiple frames at once manually. This is what this commit introduces: a sub-option controls how many frames will be requested at once. This also changes the semantics of the maxbuffer sub- option, now renamed to buffered-frames.
* manpage: updates changes.rstwm42014-05-141-46/+59
| | | | | | | | | | | | | The situation has changed a bit since the days of mplayer2, so we can use more/less diplomatic wording. Merge the two sections listing changes from MPlayer and mplayer2. Mention the client API and Lua scripting as alternatives to slave mode. I'm calling MPlayer code "horrible". This is not meant as an offense, but after turning around almost every line of MPlayer code, I believe I have a right to say this. Sorry. I would say that MPlayer has a surprisingly sane and simple architecture (for what it is), but much of it drowned under a load of evil hacks or not-cleaned-up-yet code.
* manpage: update --playlist entrywm42014-05-111-5/+10
|
* manpage: minor correctionswm42014-05-113-8/+10
|
* input: remove pausing command prefixeswm42014-05-111-3/+0
| | | | | | These are now equivalent to combining commands with the "cycle pause" or "set pause" commands, and thus are not needed anymore. They were also obscure and undocumented.
* man: tweak --sub-codepage for concisionKevin Mitchell2014-05-091-20/+18
| | | | | | | The many "boxes" in this entry were causing rst2pdf to fail because it couldn't figure out where to break the page. Make the boxes smaller by removing semi-redundant examples. Also try and make surrounding text a little shorter by rewording.
* command: add property that estimates current video FPSwm42014-05-081-0/+8
| | | | | | | | | | | | | | | | | | This is done after filters, so things like framerate-doubling deinterlacing is accounted for. Unfortunately, framedropping can cause inaccuracies (especially after precise seeks), and we can't really know when that happens. Even though we know that the decoder might drop a frame if we request it to do so, we don't know when the dropped frame will start or stop affecting the video filter chain. Video filters can have frames buffered, and we can't tell at which point the dropped frame would have been output. It's not even possible to mark a discontinuity after seek, because again we don't know if the filter chain still has the discontinuity within its buffers. So we have to live with the fact that the output of this property can be completely broken after seek, unless --no-hr-seek-framedrop is used.
* options: add --hr-seek-framedrop optionwm42014-05-072-1/+11
| | | | | | | | This allows disabling of decoder framedrop during hr-seek. It's basically another useless option, but it will help exploring whether this framedropping really makes seeking faster, or whether disabling it helps with precise seeking (especially frame backstepping).
* manpage: fix typo in previous commitwm42014-05-061-1/+1
|
* manpage: adjustments to file-size propertywm42014-05-061-1/+3
|
* command: rename stream-length to file-size, format file sizeAndrey Morozov2014-05-061-3/+3
| | | | Signed-off-by: wm4 <wm4@nowhere>
* manpage: fix vf_scale optionswm42014-05-041-9/+11
|
* options: merge ---sub-auto-match with --sub-autowm42014-05-042-10/+7
| | | | There's no reason why these should be separate.
* manpage: improve --input-cursor descriptionwm42014-05-041-2/+2
|
* options: remove deprecated --identifyMartin Herkt2014-05-042-15/+10
| | | | | | | Also remove MSGL_SMODE and friends. Note: The indent in options.rst was added to work around a bug in ReportLab that causes the PDF manual build to fail.
* options: remove obsolete --fsmode-dontuseMartin Herkt2014-05-042-4/+1
|
* options: rename device-specific optionsMartin Herkt2014-05-043-3/+5
| | | | | --dvdangle → --dvd-angle --tvscan → --tv-scan
* options: rename msg-related optionsMartin Herkt2014-05-044-21/+28
| | | | | | | | | --msgcolor → --msg-color --msglevel → --msg-level --msgmodule → --msg-module --msgtime → --msg-time (also document this one) --playing-msg → --term-playing-msg --status-msg → --term-status-msg
* options: rename video-related options/propertiesMartin Herkt2014-05-044-38/+43
| | | | | | | | | | | Renamed options: --aspect → --video-aspect --fstype → --x11-fstype --native-fs → --fs-missioncontrol --name → --x11-name Renamed properties: aspect → video-aspect
* options: rename audio-related options/propertiesMartin Herkt2014-05-044-53/+59
| | | | | | | | | | | | | Renamed options: --audiofile → --audio-file --audiofile-cache → --audio-file-cache --channels → --audio-channels --format → --audio-format --srate → --audio-samplerate Renamed properties: samplerate → audio-samplerate channels → audio-channels
* options: rename subtitle-related optionsMartin Herkt2014-05-042-48/+52
| | | | | | | | | --ass → --sub-ass --autosub → --sub-auto --autosub-match → --sub-auto-match --sub → --sub-file --subcp → --sub-codepage --subfps → --sub-fps
* options: rename input-related optionsMartin Herkt2014-05-043-51/+56
| | | | | | | | | | | --ar → --input-appleremote --consolecontrols → --input-terminal --media-keys → --input-media-keys --joystick → --input-joystick --lirc → --input-lirc --lircconf → --input-lirc-conf --mouse-movements → --input-cursor --right-alt-gr → --input-right-alt-gr
* DOCS: update changes.rstMartin Herkt2014-05-031-39/+47
| | | | | Better to tell users straight away that mpv should not be treated as just another MPlayer.
* manpage: adjust description of vdpau deint sub-optionwm42014-05-021-6/+8
|
* manpage: deprecated vo_vdpau postprocessing optionswm42014-05-021-0/+19
| | | | This seems a bit silly, but the way vf_vdpaupp works, this is cleaner.
* manpage: document vf_vdpauppwm42014-05-021-0/+49
|
* lua: remove "lua/" prefix from script nameswm42014-05-021-5/+5
| | | | | | | | | This affects the return value of mp.script_name, the "client name" (what's returned by mpv_client_name()) and all associated features, as well as the mpv terminal output module prefix when scripts print something. As discussed in #748.
* manpage: fix the alternative suggested for stream-pathwm42014-05-021-1/+1
| | | | | ${filename} didn't make much sense, since that doesn't include the path components, and can be otherwise mangled.
* man: grammar tweak of mp.add_timeout()Kevin Mitchell2014-04-291-3/+3
|
* vf_vapoursynth: use frame durations instead of _AbsoluteTimewm42014-04-281-2/+2
| | | | | | | | | | | | | Set _DurationNum/_DurationDen on each VS frame, instead of _AbsoluteTime. The duration is the difference between the timestamp of the frame and the next frame, and when receiving filtered VS frames, we convert them back to an absolute PTS by summing them. We pass the timestamps with microsecond resolution. mpv uses double for timestamps internally, so we don't know the "real" timebase or FPS. VS on the other hand uses fractions for frame durations. We can't pass through the numbers exactly, but microseconds ought to be enough to be even safe from accumulating rounding errors.
* </