summaryrefslogtreecommitdiffstats
path: root/DOCS/man/en/input.rst
Commit message (Collapse)AuthorAgeFilesLines
* DOCS: remove en/ sub-directorywm42014-06-201-1324/+0
| | | | | This additional sub-directory doesn't serve any purpose anymore. Get rid of it.
* manpage: remove some trailing whitespacewm42014-06-201-1/+1
| | | | I wish I could make github run a hook to reject these.
* command: redo ancient TV/DVB/PVR commandswm42014-06-111-5/+2
| | | | | | | | | | | | | | | | | | Convert all these commands to properties. (Except tv_last_channel, not sure what to do with this.) Also, internally, don't access stream details directly, but dispatch commands with stream ctrls. Many of the new properties are a bit strange, because they're write- only. Also remove some OSD output these commands produced, because I couldn't be bothered to port these. In general, this makes everything much cleaner, and will also make it easier to e.g. move the demuxer to its own thread. Don't bother updating input.conf, but changes.rst documents how old commands map to the new ones. Mostly untested, due to lack of hardware.
* manpage: document write_watch_later_config commandwm42014-05-271-0/+3
|
* command: add write_watch_later_config commandMartin2014-05-261-0/+3
| | | | | | Closes #808. Signed-off-by: wm4 <wm4@nowhere>
* stream: kill start_pos, remove --sb optionwm42014-05-241-4/+1
| | | | | | | | | | | | | | | | | | | | stream.start_pos was needed for optical media only, and (apparently) not for very good reasons. Just get rid of it. For stream_dvd, we don't need to do anything. Byte seeking was already removed from it earlier. For stream_cdda and stream_vcd, emulate the start_pos by offsetting the stream pos as seen by the rest of mpv. The bits in discnav.c and loadfile.c were for dealing with the code seeking back to the start in demux.c. Handle this differently by assuming the demuxer is always initialized with the stream at start position, and instead seek back if initializing the demuxer fails. Remove the --sb option, which worked by modifying stream.start_pos. If someone really wants this option, it could be added back by creating a "slice" stream (actually ffmpeg already has such a thing).
* manpage: update references to renamed optionsAlessandro Ghedini2014-05-231-1/+1
|
* player: give quit_watch_later an exit code argument like quitwm42014-05-221-3/+4
| | | | | | | | The quit command has an optional argument that is used as exit code. Extend that to the quit_watch_later command. Actually, unify the implementations of the two commands. Requested in #798.
* manpage: fix a minor aspect of the discnav commandwm42014-05-181-2/+1
| | | | | "menu" is in fact understood by stream_bluray.c, so just drop that sentence.
* manpage: document discnav commandwm42014-05-181-0/+14
|
* command: add a disc-menu-active propertywm42014-05-181-0/+6
| | | | Returns whether a DVD/BD menu is active. As requested by #788.
* manpage: minor correctionswm42014-05-111-1/+1
|
* input: remove pausing command prefixeswm42014-05-111-3/+0
| | | | | | These are now equivalent to combining commands with the "cycle pause" or "set pause" commands, and thus are not needed anymore. They were also obscure and undocumented.
* command: add property that estimates current video FPSwm42014-05-081-0/+8
| | | | | | | | | | | | | | | | | | This is done after filters, so things like framerate-doubling deinterlacing is accounted for. Unfortunately, framedropping can cause inaccuracies (especially after precise seeks), and we can't really know when that happens. Even though we know that the decoder might drop a frame if we request it to do so, we don't know when the dropped frame will start or stop affecting the video filter chain. Video filters can have frames buffered, and we can't tell at which point the dropped frame would have been output. It's not even possible to mark a discontinuity after seek, because again we don't know if the filter chain still has the discontinuity within its buffers. So we have to live with the fact that the output of this property can be completely broken after seek, unless --no-hr-seek-framedrop is used.
* options: add --hr-seek-framedrop optionwm42014-05-071-1/+2
| | | | | | | | This allows disabling of decoder framedrop during hr-seek. It's basically another useless option, but it will help exploring whether this framedropping really makes seeking faster, or whether disabling it helps with precise seeking (especially frame backstepping).
* manpage: fix typo in previous commitwm42014-05-061-1/+1
|
* manpage: adjustments to file-size propertywm42014-05-061-1/+3
|
* command: rename stream-length to file-size, format file sizeAndrey Morozov2014-05-061-3/+3
| | | | Signed-off-by: wm4 <wm4@nowhere>
* options: rename video-related options/propertiesMartin Herkt2014-05-041-2/+2
| | | | | | | | | | | Renamed options: --aspect → --video-aspect --fstype → --x11-fstype --native-fs → --fs-missioncontrol --name → --x11-name Renamed properties: aspect → video-aspect
* options: rename audio-related options/propertiesMartin Herkt2014-05-041-2/+2
| | | | | | | | | | | | | Renamed options: --audiofile → --audio-file --audiofile-cache → --audio-file-cache --channels → --audio-channels --format → --audio-format --srate → --audio-samplerate Renamed properties: samplerate → audio-samplerate channels → audio-channels
* options: rename input-related optionsMartin Herkt2014-05-041-1/+1
| | | | | | | | | | | --ar → --input-appleremote --consolecontrols → --input-terminal --media-keys → --input-media-keys --joystick → --input-joystick --lirc → --input-lirc --lircconf → --input-lirc-conf --mouse-movements → --input-cursor --right-alt-gr → --input-right-alt-gr
* manpage: fix the alternative suggested for stream-pathwm42014-05-021-1/+1
| | | | | ${filename} didn't make much sense, since that doesn't include the path components, and can be otherwise mangled.
* command: allow native access to "vf" propertywm42014-04-241-0/+16
| | | | | | This allows client API users and Lua scripts to side-step the pretty horrible video filter string "language" (although it's back and can't be avoided when using libavfilter).
* video: add a "hwdec" property to enable or disable hw decoding at runtimewm42014-04-231-0/+10
|
* command: export rotation parameterwm42014-04-221-0/+4
| | | | For completeness.
* input: discard key history when a key is mappedwm42014-04-191-4/+4
| | | | | | This is for the sake of multi-key combinations (see github issue #718). Now a multi-key sequence isn't matched if any of the previous keys were actually mapped.
* manpage: clarify one aspect of multi-keybindingswm42014-04-181-1/+2
| | | | | The explanation is kind of obvious, but on the other it'd probably be confusing not to clarify this.
* input: close window when window close button is pressed with --input-testwm42014-04-181-3/+3
| | | | | | | | | | | The window close button is usually mapped to the CLOSE_WIN pseudo-key. Until now, --input-test treated this pseudo-key like any other key (like the rest of the input handling code), so you couldn't close the window in this mode. The manpage had silly instructions and warnings how to deal with this. Just always quit when CLOSE_WIN is received, and improve the instructions.
* input: handle multi-combinations as key sequenceswm42014-04-181-0/+10
| | | | | | | | | | | | | | | | | The input code always supported combinations of multiple keys (even in MPlayer, although there the code was active really only for mouse buttons). This was arcance and also made the code more complicated. I only know of a single person who ever made use of this feature. Remove this feature, and repurpose some of the support code (e.g. parsing, display of key combinations, etc.) to handle such multi- combinations as sequences, instead of keys to be pressed at the same time. This is much simpler and implements the feature requested in github issue #718. This commit will probably cause a bunch of regressions, since the input handling code has some weird corner cases. I couldn't find any problems when testing, though.
* manpage: document loop-file propertywm42014-04-181-0/+3
| | | | Was forgotten in commit 1b398e99.
* command: add property to indicate when pausing due to --keep-openwm42014-04-141-0/+7
| | | | | | | This property is set to "yes" if playback was paused due to --keep-open. The change notification might not always be perfect; maybe that should be improved.
* command: add a property to indicate core pause statewm42014-04-141-0/+5
| | | | | | | | | Currently this is (probably) equivalent to "paused-for-cache", but the latter is a bit special, while this new property is a bit more general. One case where they might actually be different is dvdnav menus, but I haven't checked. Also add property change notifications for these two properties.
* command: add vf-metadata propertyKevin Mitchell2014-04-131-1/+12
| | | | | | | This is a read-only property that uses VFCTRL_GET_METADATA to retrieve mp_tags metadata from a filter specified by label Signed-off-by: wm4 <wm4@nowhere>
* command: add paused-for-cache, total-avsync-change, drop-frame-count propertiesDavid Weber2014-04-131-0/+11
| | | | | | | | | This is needed if you want to reimplement the status line in lua I could only test drop-frame-count because I didn't find an easy way to trigger paused-for-cache and total-avsync-change Signed-off-by: wm4 <wm4@nowhere>
* manpage: document how the client API retrieves the complicated propertieswm42014-04-111-0/+82
| | | | | "Complicated" as in they use sub-properties, and using MPV_FORMAT_NODE allows an application to retrieve all information at once.
* cache: allow resizing at runtimewm42014-04-091-0/+12
| | | | | | | | | | | The only tricky part is keeping the cache contents, which is made simple by allocating the new cache while still keeping the old cache around, and then copying the old data. To explain the "Don't use this when playing DVD or Bluray." comment: the cache also associates timestamps to blocks of bytes, but throws away the timestamps on seek. Thus you will experience strange behavior after resizing the cache until the old cached region is exhausted.
* command: allow changing filters before video chain initializationwm42014-03-301-0/+6
| | | | | | | Apparently this is more intuitive. Somewhat tricky, because of the odd state after loading a file but before initializing the VO.
* command: change what the metadata property returnswm42014-03-301-3/+9
| | | | | | | Change the type of the property from a string list (alternating key/value entries) to a map. Using the client API, this will return MPV_FORMAT_NODE_MAP, while Lua mp.get_property_native returns a dictionary-like table.
* manpage: mark disc-title as writeablewm42014-03-181-2/+3
|
* command, lua: change script_message semanticswm42014-03-171-7/+14
| | | | | | | | Change script_message to broadcast the message to all clients. Add a new script_message_to command, which does what the old script_message command did. This is intended as simplification, although it might lead to chaos too.
* command: rename dvd- properties to disc-wm42014-03-151-4/+4
| | | | Since these are not DVD-only, but can also be used with BDs.
* command: prefix DVD title properties with "dvd-"wm42014-03-151-1/+4
| | | | | | | | | | They're strictly DVD-only, so it's better to mark them as such. This also documentes the "title" (now renamed to "dvd-title") property. This also avoids collision with the --title option. (Technically, there was no problem. But it might be confusing for users, since we have a policy of naming properties and options the same if they refer to the same underlying functionality.)
* manpage: document properties added in previous commitwm42014-02-281-0/+7
|
* options: allow changing options at runtimewm42014-02-251-2/+4
| | | | | Allow changing all options at runtime, except some cherry-picked options, which are disabled with M_OPT_FIXED.
* manpage: document the new loadfile argumentwm42014-02-251-1/+6
| | | | I forgot about this.
* command: use DVD volume ID for media-title propertyxylosper2014-02-231-0/+2
| | | | | | Signed-off-by: wm4 <wm4@nowhere> Closes #582.
* manpage: fix a metadata property namewm42014-02-231-1/+1
|
* input: check for abort cmd in multi-commandswm42014-02-201-5/+0
| | | | | | | | | MP_CMD_COMMAND_LIST commands (used to implement key bindings with multiple commands) were not checked for abort commands. Implement it. Remove the remarks about multi-commands being special from the manpage. Seek coalescing is handled differently now, and the issue with abort commands is fixed with this commit.
* manpage: input: clarify chapter-metadata propertywm42014-02-191-2/+8
|
* command: allow accessing metadata entries as listwm42014-02-191-0/+12
| | | | | | Not sure about these deep path-names. Maybe "metadata/0" should work instead of "metadata/list/0". I'm so unsure about it, that I'm leaving it open.
* command: move metadata entry access to metadata/by-key/wm42014-02-191-2/+8
| | | | | | The old way still works, and is fine to use. Still discourage it, because it might conflict with other ways to access this property, such as the one added in the next commit.
* command: export list of editions as propertieswm42014-02-191-0/+22
|
* command: export codec for each trackwm42014-02-191-0/+4
|
* manpage: input: document script_message commandwm42014-02-171-0/+8
|
* command: export chapter list as propertieswm42014-02-161-0/+12
|
* command: export playlist as propertieswm42014-02-161-0/+9
|
* command: expose track list as propertieswm42014-02-161-0/+42
|
* command: export more video params as propertieswm42014-02-161-3/+40
| | | | | This uses the previously added sub-property mechanism to export a bunch of stuff. For example, "video-params/w" now contains the video width.
* manpage: reformat property listwm42014-02-121-113/+344
| | | | | | | | Use a list instead of a table. This makes it easier to provide extended information about a property, and doesn't require you to fiddle with rhe RST ASCII-art tables. Also, extend some property descriptions.
* player: add --secondary-sid for displaying a second subtitle streamwm42013-12-241-0/+1
| | | | | | | This is relatively hacky, but it's Christmas, so it's ok. This does two things: 1. allow selecting two subtitle tracks, and 2. include a hack that renders the second subtitle always as toptitle. See manpage additions how to use this.
* manpage: mention video-unscaled propertywm42013-12-231-0/+1
|
* command: remove radio commandswm42013-12-191-2/+1
| | | | | | | Remove these because I'm too lazy to convert them to proper STREAM_CTRLs. Considering that probably nobody uses radio://, caring about this is a complete waste of time. I will add these commands back if someone asks for them, but I don't expect this to happen.
* command: scale osd’s time remaining by the current speedVivek Jain2013-12-161-0/+1
| | | | Signed-off-by: wm4 <wm4@nowhere>
* manpage: undocument syntax for skipping optional arguments in input commandswm42013-12-161-2/+0
| | | | | | | | "-" could skip optional arguments. I think this was a pretty bad idea, because it introduced a weird special case. I'll remove the special syntax, but keep compatibility for the "seek" and "screenshot" commands.
* manpage: mention that the "run" does not wait for the commandwm42013-12-141-0/+3
|
* manpage: mark "run" command as Unix-onlywm42013-12-071-0/+1
|
* options: add option to disable using right Alt key as Alt GrVivek Jain2013-12-021-0/+4
| | | | | | | | | mpv was hardcoded to always consider the right Alt key as Alt Gr, but there are parituclar combinations of platforms and keyboard layouts where it's more convenient to treat the right Alt as a keyboard modifier just like the left one. Fixes #388
* command: add a revert_seek commandwm42013-12-011-0/+6
| | | | As discussed on IRC.
* command: add a cycle_values input commandwm42013-11-301-0/+18
|
* command: change the syntax and semantics of the "run" commandwm42013-11-301-3/+18
| | | | | | | See the changes in input.rst for explanations. Technically speaking, this also gets rid of some undefined behavior: passing NULL as a vararg (execl()) is always a bug.
* command: allow "current" as argument to playlist_remove commandwm42013-11-281-2/+4
| | | | Feature request from github issue #376.
* command: replace speed_mult with multiply commandwm42013-10-311-3/+0
| | | | The compatibility layer still takes care of the old speed_mult command.
* command: add generic "multiply" commandwm42013-10-31