summaryrefslogtreecommitdiffstats
path: root/DOCS/interface-changes.rst
Commit message (Collapse)AuthorAgeFilesLines
* Release 0.37.0v0.37.0release/0.37sfan52023-11-211-4/+2
|
* options: add more properties to default watch-later-optionsKacper Michajłow2023-11-121-0/+1
| | | | | | | | | | | | | | | | | | | Adds: --secondary-sub-visibility --video-aspect-method --video-unscaled --video-pan-x --video-pan-y --video-rotate --video-crop --video-zoom --video-scale-x --video-scale-y --video-align-x --video-align-y Those properties are related to playback state and are likely expected to be restored when resuming playback.
* options: remove not relevant props from default watch-later-optionsKacper Michajłow2023-11-121-0/+2
| | | | | | | | | | | | Removes: --border --fullscreen --ontop --osd-level --pause Those options are not really content related. I don't see much gain to save them per each watch later entry.
* cocoa: remove OpenGL cocoa backendder richter2023-11-101-0/+1
| | | | | | the OpenGL cocoa backend was deprecated in 0.29, it has lot of bugs, is completely unmaintained and can't properly playback anything anymore on the newest macOS. it is time to remove it.
* mac: change display name retrieval to localizedName NSScreen propertyder richter2023-11-101-0/+2
| | | | | | | | | | | | | | | the old displayName property via the IODisplay API is not working anymore on ARM based macs and was broken in at least one other case. instead we use the new localizedName property introduced in 10.15 of the NSScreen. we don't need any backwards compatibility since 10.15 is the oldest version we support now. configs and scripts that use the options and properties fs-screen-name, screen-name or display-names need to be adjusted since the names could differ from the previous implementation via the IODisplay API. Fixes #9697
* vo_gpu_next: add --target-gamut optionNiklas Haas2023-11-081-0/+1
| | | | Fixes: https://github.com/mpv-player/mpv/issues/12777
* player/command: remove hdr-metadata propertyKacper Michajłow2023-11-051-0/+1
| | | | | It is now included in video-out-params and was never released in stable version, so we can safely remove it.
* csputils: add pl_hdr_metadata to mp_colorspace and deprecate sig_peakKacper Michajłow2023-11-051-0/+1
| | | | | Note this commit does not change all uses of sig-peak, this is for future refactoring.
* demux: make hysteresis-secs respect cache-secsNRK2023-10-301-0/+2
| | | | | | | | | | | | currently hysteresis-secs only works when the demuxer-max-bytes fills up. but it's possible for the cache-secs/demuxer-readahead-secs to be reached first. in those cases, hysteresis-secs doesn't work and keeps buffering non-stop. but the goal of this option was to save power by avoiding non-stop buffering so go ahead and make it respect cache-secs as well. additionally remove some redundant repetition from the docs.
* m_option: drop support for -del for list optionsDudemanguy2023-10-301-0/+1
| | | | | | 5f74ed58286a1339412554932f31844ec1b64280 deprecated this many years ago. The utility is questionable at best given that -remove exists and is more natural to use. Free up some code and drop it.
* options: make --screenshot-directory/--watch-later-directory aliasesDudemanguy2023-10-301-2/+2
| | | | By popular demand I guess.
* javascript: use --js-memory-report option instead of MPV_LEAK_REPORTDudemanguy2023-10-261-0/+2
| | | | | | | | The MPV_LEAK_REPORT environment variable was previously read in order to determine whether or not to enable memory reporting for javascript scripts. This is kind of weird and deviates from the norm of exposing an option to the user. So let's just add --js-memory-report and disable it by default instead.
* options: rename --play-dir to --play-directionDudemanguy2023-10-251-0/+1
| | | | | | --play-dir sounds like it has something to do with directories so change it. The play_dir variable is used a bunch everywhere internally so whatever just leave it alone instead of renaming that.
* options: rename --watch-later-directory to --watch-later-dirDudemanguy2023-10-251-0/+1
| | | | Same logic as the previous commit.
* options: rename --screenshot-directory to --screenshot-dirDudemanguy2023-10-251-0/+1
| | | | | Less characters is better? Other options use -dir for directory so consistency I guess.
* options: rename --sub-ass-force-style to --sub-ass-style-overridesDudemanguy2023-10-251-0/+1
| | | | | | | This option has exactly the same semantics are other mpv options that override a particular thing with something from the user. So instead of the "force-style" name, use "-overrides" which is more consistent. The plural form is used since it's a list option.
* options: rename --override-display-fps to --display-fps-overrideDudemanguy2023-10-251-0/+1
| | | | | | Other similar options are in the form of --foo-override not --override-foo. The display-fps one was backwards so flip it around the other way for consistency reasons.
* options: rename --fps to --container-fps-overrideDudemanguy2023-10-251-0/+1
| | | | | | This better reflects what it actually does. As a bonus, script writers won't be misled into thinking that fps displays the actual video or display fps.
* options: disable --allow-delayed-peak-detect by defaultKacper Michajłow2023-10-251-0/+1
| | | | | | Peak detection greatly increases HDR experience. Performance hit of non-delayed detection is not that significant and is in line with current default settings.
* stream_cdda: deprecate --cdda-toc-bias and always check for offsetsDudemanguy2023-10-191-0/+1
| | | | | | | | | | | | | | | | I started going through the blame but once I got to mplayer commits from 20 years ago, I stopped bothering. This obscure option has always been disabled by default, but there's zero reason, as far as I know, to not just enable it today. Some CDs (particularly very old ones) have the first sector shifted a bit and not starting exactly at 0. This makes the logic that tries to get all the chapters completely fail and thus you can't skip through tracks. However if you just enable this obscure option, it just works. For anything that starts exactly at 0, the calculated offset is just 0 anyway so it's a no-op and works exactly the same. So basically, there's literally no reason to not just always try to correct for the offset of the first sector by default. Fixes #8777.
* DOCS/interface-changes: remove redundant changeGuido Cella2023-10-171-1/+0
| | | | directory-mode's default was changed again to auto afterwards.
* f_decoder_wrapper: change video-codec to show description or nameKacper Michajłow2023-10-141-0/+1
| | | | | | | | Not both of them. Formating it as `<name> (<desc>)` produced arguably silly string like `hevc (HEVC (High Efficiency Video Coding))`. Unpack this to show only description if available or name otherwise. Produces way nicer results in stats.lua and similar places where this name is printed.
* command: add playlist-next-playlist and playlist-prev-playlistGuido Cella2023-10-091-0/+1
| | | | | | | | | | | | playlist-prev-playlist goes to the beginning of the previous playlist because this seems more useful and symmetrical to playlist-next-playlist. It does not go to the beginning when the current playlist-path starts with the previous playlist-path, e.g. with mpv --loop-playlist foo/, which expands to foo/{1..9}.zip, the current playlist path foo/1.zip beings with the playlist-path foo/ of {2..9}.zip and thus playlist-prev-playlist goes to 9.zip rather than to 2.zip. Closes #12495.
* demux: change the default of metadata-codepage to autoDudemanguy2023-10-071-0/+1
| | | | | | | There's really no reason not to do this especially since sub-codepage already defaults to auto. Also change logging in charset_conv since telling us that the data is UTF-8 if the passed codepage value is "auto" or "utf-8" is really not useful information (that's the expectation).
* demux_cue: deprecate --demuxer-cue-codepage for --metadata-codepageDudemanguy2023-10-071-0/+1
| | | | | | | | | What are cue sheets not metadata or something? No reason this needs to be a separate option so just deprecate it. This does mean that the default value changes from "auto" to "utf-8" for this obscure fringe case. I really hope people don't use non-UTF-8 cuesheets, but the next commit will change the default of --metadata-codepage to "auto" so there's no actual change in behavior to users.
* path: don't override "cache" and "state" paths with configdirsfan52023-10-021-0/+1
| | | | | | | | | | This reverts commit 576e86bfa18a0a79e591988ad93ed009edc40849 (functionally). Right now, the --config-dir option silently causes all watch_later and cache files to be written in the --config-dir as well. This is pretty uninitutive and also not desirable in most cases so get rid of this. libmpv users will have to set the corresponding options or env vars if they want to keep the old behaviour.
* DOCS/interface-changes: also mention --window-affinityDudemanguy2023-10-011-0/+1
| | | | | Added in 2c738ca54b16cdd1982473672bd39068fcf8d948. I guess we seem to always mention any added option these days so might as well.
* DOCS/interface-changes: mention --backdrop-typeKacper Michajłow2023-10-011-0/+1
| | | | Added in f19ada7b583e9bf78de38d228a956c365b5c417b
* command: deprecate shared-script-propertiesDudemanguy2023-09-271-0/+1
| | | | user-data is simply better.
* vo_gpu: remove --scaler-lut-sizeNiklas Haas2023-09-251-0/+1
| | | | | | | Pointless bloat option, hard-coded as 256 now in libplacebo and no reason not to also hard-code in mpv. See-Also: haasn/libplacebo@64d7c5aab06766a9492d3cfffd35333792052cd9
* vo_gpu: remove --scale-cutoff etcNiklas Haas2023-09-251-0/+1
| | | | | | | Pointless bloat option, hard-coded as 1e-3 now in libplacebo and no reason not to also hard-code in mpv. See-Also: haasn/libplacebo@64d7c5aab06766a9492d3cfffd35333792052cd9
* stream_cdda: move cdrom-device to cdda_paramsDudemanguy2023-09-221-0/+1
| | | | | | There is zero reason for this to be an MPOpt. Because of how the OPT_SUBSTRACT works, the option gets renamed to cdda-device instead, but probably not a big deal since the old alias is still in place.
* win32: add --window-cornersKacper Michajłow2023-09-211-0/+1
| | | | Allows to set preference for window corners rounding for DWM.
* win32: add an option to control window title bar stateKacper Michajłow2023-09-211-0/+1
| | | | Fixes: #11432
* drm: remove selecting the card number with --drm-connectorDudemanguy2023-09-211-0/+2
| | | | | | f56043759494dd584c8d82e7890f92fada18e34b deprecated this since the --drm-device path option was added as a replacement. Drop the card number selection logic.
* options: remove --vf-defaults and --af-defaultsDudemanguy2023-09-211-0/+1
| | | | | | | These were deprecated a long time ago and apparently didn't even work with lavfi filters. Go ahead and remove them and additionally clean up some code related to them. m_config_from_obj_desc_and_args becomes much simpler now and a couple of arguments can be completely removed.
* options: remove deprecated --record-file optionDudemanguy2023-09-211-0/+1
| | | | | | No wonder wm4 wanted to get rid of this. This option requires touching a bunch of crap in the core player code. --stream-record works perfectly fine and is a lot nicer so there's no need for this to exist anymore.
* options: remove a few options marked with .deprecation_messageDudemanguy2023-09-211-0/+2
| | | | | | | | | | | A bit different from the OPT_REPLACED/OPT_REMOVED ones in that the options still possibly do something but they have a deprecation message. Most of these are old and have no real usage. The only potentially controversial ones are the removal of --oaffset and --ovoffset which were deprecated years ago and seemingly have no real replacement. There's a cryptic message about --audio-delay but who knows. The less encoding mode code we have, the better so just chuck it.
* command: stop restarting playback when writing to playlist-posDudemanguy2023-09-211-0/+2
| | | | | | | | | e9e93b4dbe748cd341a6fbea355e6ba013ada81b added a warning about writing the same value to the playlist-pos property that in the future it would stop restarting playback. Instead, you should use the playlist-play-index command for that. Well go ahead and drop the old deprecated behavior now and do what wm4 wanted this to do: just ignore if the same value is written again.
* command: remove some old deprecated properitiesDudemanguy2023-09-211-0/+3
| | | | | | | | drop-frame-count and vo-drop-frame-count are ancient and have no reason to exist anymore. The other change is that support for writing to display-fps has been removed, and the property is strictly read-only now. 3a2dc8b22e9f947c9cd3a91445b0731b8df1d798 is what deprecated it with a warning to users, so we can remove it without much trouble.
* options: remove ancient option fallbacks/deprecationDudemanguy2023-09-211-0/+2
| | | | | | | | | | | | | We've got an ungodly amount of OPT_REPLACED and OPT_REMOVED sitting around in the code. This is harmless, but the vast majority of these are ancient. 26f4f18c0629998a9b91e94722d166866d8b80a3 is the last commit that touched the majority of these and of course that only changed how options were declared so all of this stuff was deprecated even before that. No use in keeping these, so just delete them all. As an aside, there was actually a cocoa_opts but it had only a single option which was replaced by something else and empty otherwise. So that entire thing was just simply removed. OPT_REPLACED/OPT_REMOVED declarations that were added in 0.35 or later were kept as is.
* builtin.conf: remove deprecated opengl-hq profileDudemanguy2023-09-211-0/+1
| | | | | Deprecated in 65979986a923a8f08019b257c3fe72cd5e8ecf68. 6 years is more than enough time.
* demux_playlist: add --directory-mode=autoGuido Cella2023-09-211-0/+1
| | | | This is a more useful default with --shuffle.
* vo_gpu: match libplacebo debanding defaultsNiklas Haas2023-09-201-0/+1
| | | | | | | | | The defaults were awful and horribly regressed many files while also not fixing banding on files that actually needed it, sometimes even *increasing* banding due to the low threshold. Fixes: 12ffce0f224056f91a20c9f0b197f4973931efbe See-Also: haasn/libplacebo@e1e43376d16d5112ee1254534664b0b85110139b
* vo_gpu: match libplacebo peak detection defaultsNiklas Haas2023-09-201-0/+2
| | | | | | | | | This probably makes `vo_gpu` tone mapping worse, or something, but who cares. The status quo for a while now has been to use `vo_gpu_next` if you care about HDR rendering at all. See-Also: haasn/libplacebo@ec60dd156b82753a2e2d8a399899244605f4d1bf See-Also: haasn/libplacebo@0903cbd05d7fc0391cbd99954924a39b855c8a1b
* vo_gpu: default to dscale=hermiteNiklas Haas2023-09-201-0/+1
| | | | | | | | | | This new filter is slightly sharper, and significantly faster, than mitchell. It also tends to preserve detail better. All in all, there is no reason not to use it by default, especially from a performance PoV. (In vo_gpu_next, hermite is implemented efficiently using hardware accelerated bilinear interpolation) See-Also: https://code.videolan.org/videolan/libplacebo/-/commit/75b3947b2c07803456483ec6976c037bad91b5dd
* builtin.conf: modernize internal profilesKacper Michajłow2023-09-191-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The goal is to provide simple to understand quality/performance level profiles for the users. Instead of default and gpu-hq profile. There main profiles were added: - fast: can run on any hardware - default: balanced profile between quality and performance - high-quality: out of the box high quality experience. Intended mostly for dGPU. Summary of three profiles, including default one: [fast] scale=bilinear cscale=bilinear (implicit) dscale=bilinear dither=no correct-downscaling=no linear-downscaling=no sigmoid-upscaling=no hdr-compute-peak=no [default] (implicit mpv defaults) scale=lanczos cscale=lanczos dscale=mitchell dither-depth=auto correct-downscaling=yes linear-downscaling=yes sigmoid-upscaling=yes hdr-compute-peak=yes [high-quality] (inherits default options) scale=ewa_lanczossharp cscale=ewa_lanczossharp (implicit) hdr-peak-percentile=99.995 hdr-contrast-recovery=0.30 allow-delayed-peak-detect=no deband=yes scaler-lut-size=8
* vo: change tscale to oversample by defaultKacper Michajłow2023-09-191-0/+1
| | | | Keep it sharp, let users opt-in more blurry result.
* vo: make cscale follow scale by defaultKacper Michajłow2023-09-191-0/+1
|
* vo: enable correct-downscaling, linear-downscaling, sigmoid-upscalingKacper Michajłow2023-09-191-0/+1
|
* demux: prepend some cache options with demuxerDudemanguy2023-09-181-0/+2
| | | | | | --cache-dir is an awful name that leads to confusion (see #12418). Change the name to --demuxer-cache-dir and --demuxer-cache-unlink-files instead.
* filter_kernels: remove bcspline filterllyyr2023-09-181-0/+1
| | | | | | After fixing the B and C params for bcspline, it ended up being the same thing as bicubic. There's no reason to have two names for the same filter, so remove bcspline and keep bicubic to match libplacebo.
* vo_gpu: remove --scale-wblur etcNiklas Haas2023-09-161-0/+1
| | | | | | | | | | No need for this since it's entirely redundant with just changing the filter radius directly. In fact, that's the whole *point* of the filter radius - it does not modify the filter, it modifies the scaling of the window. Of course, this does not work for non-resizable kernels. But, really, who cares?
* filter_kernels: add ewa_lanczos4sharpestNiklas Haas2023-09-161-0/+1
| | | | Mainly for vo_gpu_next.
* vo_gpu: vo_gpu_next: support --icc-3dlut-size=autoNiklas Haas2023-09-151-0/+1
| | | | | | | | | | | | And make it the default. In libplacebo, this uses internal heuristics to pick a good size based on the actual ICC characteristics. This is significantly less wasteful than always generating a 64x64x64 3DLUT (the old status quo). In vo_gpu, for simplicity, just default to 65x65x65. Note that this provides slightly better accuracy than the old default of 64x64x64 for technical reasons, and matches what libplacebo defaults to for typical display profiles.
* Revert "sub: add auto option to --sub-fix-timing"Kacper Michajłow2023-09-111-1/+0
| | | | This reverts commit b47a58516af2c36e66c3987748b5b4a1275ed9e7.
* player: redo --subs-fallback-forcedDudemanguy2023-09-091-0/+1
| | | | | | | | | | | | | In the never ending quest of trying to satisfy every possible user request for subtitle autoselection, I ended up redoing how --subs-fallback-forced works. The old behavior had it as strictly a fallback-type option when there were no lang matches, but now we can make it an active part of compare_track and it works along with slang to select the desired track. Since it's a three state option, the no option still works to avoid selecting any forced subtitle tracks. The meaning of always slightly changes to mean "only select forced subtitle tracks" and yes remains essentially the same (no special priority given besides the audio matching subtitle language case).
* sub: add auto option to --sub-fix-timingDudemanguy2023-09-071-0/+1
| | | | | | | | | Third try is the charm? I stupidly missed that this option already existed in my previous commits. Instead, add an auto value to it and enable it by default for sd_lavc but not sd_ass. On my limited samples, it seems to fix the gaps issue that can occur but without regressing some duration timings for sub_lavc subtitles. Well hopefully anyway. Fixes #12327.
* Revert "aspect: change --video-pan-x/y to be relative to the destination rect"llyyr2023-09-021-1/+0
| | | | | | | | | | | | | There are way too many preexisting scripts that rely on this behavior for video panning, like for example scripts that allow you to use mpv as an image viewer. If this behavior is desired then it may be better to add a new option for pann