summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* demux_lavf: blacklist "tty" libavformat demuxerv0.1.0wm42013-08-071-1/+16
| | | | | | | | | | This is completely useless, and in this particular case, it broke the fallback for MLP2 subtitles (stored as .txt files) to demux_subreader. (Yes, libavformat should be fixed to handle this, but for now this will _always_ break playback of subtitle files stored in .txt.) You can still force this demuxer, but by default we will just pretend that the "tty" demuxer does not exist.
* changes.rst: add precise scrolling supportAlexander Preisinger2013-08-071-0/+2
|
* input.conf: better documentation and sane defaultsAlexander Preisinger2013-08-071-2/+4
| | | | | Uses the same defaults as BTN3/4/5/6 which are hardcoded by most backends for the mouse wheel.
* wayland: add support for precise scrollingAlexander Preisinger2013-08-071-2/+14
| | | | | | | | The default value for a standard mouse is 10.0. Because we don't want to multiply the value in the input config file we scale it down to 1.0. Hopefully this should work for more precise mousewheels or touchpad, but I don't have access to such hardware.
* input: add support for precise scroll axesAlexander Preisinger2013-08-075-3/+39
| | | | | | | | | | | | | | | Support horizontal and vertical axes of input devices. If the input device support precise scrolling with an input value then it should first be scaled to a standard multiplier, where 1.0 is the default. The multiplier will then applied to the following commands if possible: * MP_CMD_SEEK * MP_CMD_SPEED_MULT * MP_CMD_ADD All other commands will triggered on every axis event, without change the values specified in the config file.
* core: move contents to mpvcore (2/2)Stefano Pigozzi2013-08-06211-517/+517
| | | | Followup commit. Fixes all the files references.
* core: move contents to mpvcore (1/2)Stefano Pigozzi2013-08-0667-0/+0
| | | | | | | | | | core is used in many unix systems for core dumps. For that reason some tools work under the assumption that the file is indeed a core dump (for example autoconf does this). This commit just renames the files. The following one will change all the includes to fix compilation. This is done this way because git has a easier time tracing file changes if there is a pure rename commit.
* gl_video: handle non-mod-2 4:2:0 YUV video correctlywm42013-08-062-2/+14
| | | | | | | | | | | | | | | | Allocate textures big enough to include the bottom/right borders (so the chroma texture sizes are rounded up instead of down). Make the texture large enough to include the additional luma border. Conceptually, we pretend that the video frame is fully aligned, and then crop away the unwanted borders. Filtering (even just bilinear) will access the borders anyway, so it's possible that we might need to switch to "harder" cropping instead, but at least pixels not close to the border should be displayed correctly now. Add a comment to mp_image.c about this luma border. These semantics are kind of subtle, and the image allocation code handle this in a subtle way too, so it's better to document this explicitly. The libavutil image allocation code does similar things.
* Merge pull request #154 from rossy2401/wasapi-pauseDiogo Franco2013-08-051-1/+2
|\ | | | | WASAPI stops working after pause
| * ao_wasapi: don't check the audio feed while pausedJames Ross-Gowan2013-07-271-1/+2
| |
* | changes.rst: mention wayland supportAlexander Preisinger2013-08-051-0/+1
| | | | | | | | In case website copy&paste outdated information again.
* | mp_msg: fix typo in commentwm42013-08-051-1/+1
| |
* | stream_radio: fix some thingswm42013-08-053-5/+5
| | | | | | | | | | | | | | | | | | Using the radio set/step channel commands would have crashed (that was broken for about a year, nobody ever noticed). The "capture" part of a radio:// URI was incorrectly passed (this was broken quite recently). Still couldn't test it fully. I have no radio device. I suspect nobody uses this feature or will ever use it again.
* | core: change speed option/property to doublewm42013-08-056-17/+18
| | | | | | | | | | | | | | | | | | | | | | | | | | The --speed option and the speed property used float. Change them to double. Change the commands that manipulate the property (speed_mult/add) to double as well. Since the cycle command shares code with the add command, we change that as well. The reason for this change is that this allows better control over speed, such as stepping by semitones. Using floats is also just plain unnecessary.
* | demux_lavf: make avio buffer configurablewm42013-08-043-6/+15
| | | | | | | | | | | | Perhaps not very useful, but reserved for situations when a user reports awful latency and experimentation/debugging might be required to find out why or to fix it (happens often).
* | demux_lavf: fix API usagewm42013-08-041-2/+10
| | | | | | | | | | | | | | | | | | avio_alloc_context() is documented to require an av_malloc'ed buffer. It appears libavformat can even reallocate the buffer while it is probing, so passing a static buffer can in theory lead to crashes. I couldn't reproduce such a crash, but apparently it happened to mplayer-svn. This commit follows the mplayer fix in svn commit r36397.
* | option: fix inverted --mouseinput optionwm42013-08-031-1/+1
| | | | | | | | Also fixes --no-mouseinput.
* | command: make vf and af commands more verbosewm42013-08-032-2/+25
| | | | | | | | | | | | On success, print the filter chain on the OSD. Otherwise, show an error message on the OSD (just enough so that the user knows whether the command worked).
* | command: add vf/af propertieswm42013-08-033-1/+63
| |
* | command: split filter changing in two functionswm42013-08-031-39/+49
| | | | | | | | | | One function sets a raw filter list, the other allows "editing" the filter list.
* | options: don't make options set during playback file local (e.g. --vf)wm42013-08-027-81/+67
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Refactor file local options handling: instead of making all options implicitly file local between loading a file and terminating playback, explicitly make options file local which are required to be file local. Or in other words, introduce a M_SETOPT_BACKUP flag, which forces file local-ness when setting an option, and use this for file local command line options, per-file config files, and per-protocol/extension/vo/ao profiles. In particular, this changes the "vf" input command such that video filters stay permanent even when going to the next file in the playlist. The underlying reason for this is that the "vf" command uses the option setting command. This influences the "af" command as well.
* | configure: lower libdvdread minimum required versionwm42013-08-021-1/+1
| | | | | | | | | | | | | | | | | | This version number was essentially random. When I switched the test to pkg-config, I took the libdvdread version from my Debian unstable system as the minimum (as I knew that this version worked). A user reported that the libdvdread version 4.1.4 appeared to work fine, so lower the minimum version to the 4.1.x series.
* | m_option.c: fix typo in messagewm42013-08-021-1/+1
| |
* | m_config: minor simplificationwm42013-08-021-11/+10
| | | | | | | | | | The optstruct parameter in the m_config_parse_option functions was not needed.
* | stream: parse URL escapes for file://wm42013-08-024-0/+41
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | So for example "file:///file%20name.mkv" will open "file name.mkv". I'm not sure whether we want/need this. The old code didn't do it. Also, it's not really clear whether this is handled correctly. It seems the corresponding freedesktop.org "standard" allows a (useless) hostname part, which we should skip in theory. The number of slashes is not really clear either. We can open relative filenames (by removing one of the slashes from the example above), which is perhaps an unneeded feature. How does this even work with Windows paths? This issues can probably be corrected later. The URL unescape code is based on code from m_option.c removed with a recent commit.
* | Remove m_structwm42013-08-026-208/+0
| | | | | | | | Not needed anymore.
* | stream: redo URL parsing, replace m_struct usage with m_configwm42013-08-0222-592/+281
| | | | | | | | | | | | | | | | | | | | | | | | | | Move the URL parsing code from m_option.c to stream.c, and simplify it dramatically. This code originates from times when http code used this, but now it's just relict from other stream implementations reusing this code. Remove the unused bits and simplify the rest. stream_vcd is insane, and the priv struct is different on every platform, so drop the URL parsing. This means you can't specify a track anymore, only the device. (Does anyone use stream_vcd? Not like this couldn't be fixed, but it doesn't seem worth the effort, especially because it'd require potentially touching platform specific code.)
* | manpage: clean up environment variables sectionwm42013-08-021-54/+32
| |
* | manpage: document exit codeswm42013-08-021-0/+18
| |
* | manpage: move screenshot section above option listwm42013-08-021-17/+17
| | | | | | | | | | Seems more logical, because general usage instructions are before the option list as well.
* | mplayer: add more verbose exit codesAndre D2013-08-023-17/+61
| |
* | encoding-example-profiles: get rid of the N900 anti upscale hack.Rudolf Polzer2013-08-021-1/+1
| | | | | | | | | | | | This slightly increases file size due to needless downscaling on the device due to aspect correction, but keeps quality as is and prevents encoding errors caused by odd height/width.
* | ao_coreaudio: move to new log APIStefano Pigozzi2013-08-014-99/+101
| |
* | ao_coreaudio: remove useless definesStefano Pigozzi2013-08-011-3/+0
| | | | | | | | They are already defined in the header file
* | audio/out: add support for new logging APIStefano Pigozzi2013-08-013-10/+18
| |
* | vo_corevideo: use new log APIStefano Pigozzi2013-08-011-15/+5
| | | | | | | | | | Also removes the printing of the OpenGL info when using verbose mode since gl_common already does that.
* | vo_corevideo: move to C from Objective-CStefano Pigozzi2013-08-013-42/+12
| | | | | | | | | | This file was alredy written in C. The only remaining part was the file exension and `#import`s.
* | cocoa_common: use new log APIStefano Pigozzi2013-08-011-7/+11
| |
* | wayland: switch to the new mp_msg apiAlexander Preisinger2013-07-313-8/+23
| |
* | video/out: use new mp_msg stuff for vo.c and vo_openglwm42013-07-318-83/+97
| | | | | | | | The first step; also serves as example.
* | mp_msg: introduce new log functions and macroswm42013-07-315-66/+255
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This has two goals: 1. Getting rid of global variables to make the core library-safe. 2. Getting rid of all the MSGT_* constants and the inconsistent prefixes spread throughout the source code. Both goals are not immediately reached with this commit. It's a huge transition that will take time. There are over >2500 mp_msg calls in the source, which all have to be replaced for this to work. The inconsistent prefixes are in particular annoying. Lots of code manually prefixes messages, e.g. mp_msg(MSGT_VO, MSGL_V, "[vo] ..."). Sometimes the prefixes don't even follow this convention (for example vo_direct3d.c uses "<vo_direct3d>" as prefix). This commit allows automatically adding prefixes on request, so consistency will hopefully improve. For now, this commit adds unused stuff, and behavior should not change. In mplayer.c, move the GetCpuCaps() call, because that used mp_msg() before mp_msg_init() was run.
* | options: handle presets directly in m_configwm42013-07-316-36/+48
| | | | | | | | | | This means that "mpv -vo opengl-hq:help" will actually show the correct defaults, instead those of plain vo_opengl.
* | m_option: fix skipping of missing -vo/-ao entrieswm42013-07-311-3/+9
| | | | | | | | | | | | | | | | | | The -vo/-ao options support skipping of unknown entries for the sake of allowing using the same config on possibly very different systems, which have different sets of VO/AOs available. Unfortunately skipping didn't quite work, possibly a rebase error when this was originally committed. Fix it.
* | m_config: remove alias informationwm42013-07-312-24/+12
| | | | | | | | | | | | | | | | | | | | | | | | We don't need to store anymore whether an option is aliased by another option (which is what the alias_owner member did). Also, that member had a really bad name. This also removes some unneeded code from config_destroy(). Calling m_option_free() is always ok; this just skipped the call if it did nothing. In particular, it's ok to call m_option_free() on the same pointer multiple times. (Maybe that function is misnamed, and it should be m_option_clear().)
* | m_config: store file local backup options differentlywm42013-07-312-16/+31
| | | | | | | | | | | | | | | | | | | | | | File local options need to backup the global option value while a file is played. Instead of keeping a pointer in m_config_option for the backup value, put it into a separate list. This reduces per-option overhead for a rarely used obscure feature. (This implementation would have been a bit dumb in pre-mpv m_config, because there local options were the default, and _all_ options were backed up when starting playback of a file. This is not the case anymore, and normally only a very small number of options are backed up by default.)
* | m_config: make m_profile struct non-publicwm42013-07-312-13/+11
| |
* | cocoa_common: simplify resize codeStefano Pigozzi2013-07-301-51/+16
| | | | | | | | | | | | | | | | | | | | This introduces some changes in resize behaviour. Most importantly the window frame is not constrained to it's screen's `visibleFrame`. Anyone who still wants that kind of behaviour when opening a video, can use `--autofit-larger`. Even though the size of the window is not constrained, it's position is, so that the titlebar will always be visible. When using `--no-border` even the position will not be constrained in any way.
* | vd_lavc: print warning if hardware decoding API is not availablewm42013-07-301-0/+3
| | | | | | | | | | At least currently, this case pretty much happens only in the case vdpau is requested, but not compiled in.
* | vd_lavc: fix CONFIG_VDPAU checkwm42013-07-301-1/+1
| | | | | | | | | | | | CONFIG_VDPAU was just defined to 0, instead of undefined when vdpau was unavailable. I blame the old mplayer code, which apparently can't have consistent conventions.
* | configure: fix vdpau test if vdpau is disabled/unavailablewm42013-07-301-5/+8
| | | | | | | | | | | | | | | | | | The check for HAVE_AV_CODEC_NEW_VDPAU_API just determines whether the new vdpau libavutil pixel format is available (which implies presence of the new API). However, that pixel format (and the correspondig config test define) is also used in generic code (compiled even without vdpau) in fmt-conversion.c. Since the configure test didn't define the symbol if vdpau was not available, it broke in this case.
* | mpv.rc: update Windows iconJames Ross-Gowan2013-07-305-2/+66
| | | | | | | | Based on the OSX bundle icon.
* | crosscompile-mingw.txt: it's "MinGW" not "MingGW"wm42013-07-301-3/+3
| |
* | crosscompile-mingw.txt: mingw-w64 now has modern OpenGL headers in trunkwm42013-07-301-1/+1
| |
* | stream: remove inactive URL option fieldswm42013-07-303-23/+0
| | | | | | | | | | | | | | | | | | The URL option parser only accesses certain fields. Remove the fields that are not accessed, and thus are completely unused and inaccessible. Historically, these fields were supposed to be settable using an extra list of options passed to open_stream(). Commit f518cf7 removed these extra options. Apparently nothing ever actually used this facility.
* | stream_dvd: fix .ifo redirectionwm42013-07-301-2/+1
| | | | | | | | This was blatantly broken after stream->url was changed to talloc.
* | Fix some warningsJonathan Yong2013-07-301-6/+6
| |
* | ao_coreaudio: use default output unit when no device is specifiedStefano Pigozzi2013-07-291-1/+3
| | | | | | | | | | | | Using the default output audio unit should provide a much better user exeperience since it changes automatically the output device based on which becomes the default one.
* | command: silence a warningwm42013-07-291-0/+2
| | | | | | | | | | This is unreachable code, but the compiler doesn't always determine this. This change shuts up the warning in these cases.