summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 29960196b3..3250ad4e67 100644
--- a/meson.build
+++ b/meson.build
@@ -359,6 +359,10 @@ features += {'win32-threads': win32_threads.allowed()}
if not features['win32-threads']
pthreads = dependency('threads')
sources += files('osdep/threads-posix.c')
+ features += {'pthread-condattr-setclock':
+ cc.has_header_symbol('pthread.h',
+ 'pthread_condattr_setclock',
+ dependencies: pthreads)}
dependencies += pthreads
endif