summaryrefslogtreecommitdiffstats
path: root/generated/player/lua/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'generated/player/lua/meson.build')
-rw-r--r--generated/player/lua/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/generated/player/lua/meson.build b/generated/player/lua/meson.build
new file mode 100644
index 0000000000..362c87cbb7
--- /dev/null
+++ b/generated/player/lua/meson.build
@@ -0,0 +1,10 @@
+lua_files = ['defaults.lua', 'assdraw.lua', 'options.lua', 'osc.lua',
+ 'ytdl_hook.lua', 'stats.lua', 'console.lua', 'auto_profiles.lua']
+foreach file: lua_files
+ lua_file = custom_target(file,
+ input: join_paths(source_root, 'player', 'lua', file),
+ output: file + '.inc',
+ command: [file2string, '@INPUT@', '@OUTPUT@'],
+ )
+ sources += lua_file
+endforeach