summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 11 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 17c06b0621..5a775b8906 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,10 @@
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
#export DH_VERBOSE=1
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
+
+# do not run the actual rules of this makefile in parallel. sub-makes
+# can go in parallel
+.NOTPARALLEL:
package := mplayer
prefix := $(shell pwd)/debian/$(package)
@@ -14,6 +16,11 @@ arch := $(shell dpkg --print-architecture)
# https://wiki.ubuntu.com/DistCompilerFlags
CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(NUMJOBS)
+endif
+
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -23,7 +30,7 @@ configure-stamp:
# you may want to add the "--enable-runtime-cpudetection" option to
# the line below, but beware: the resulting binary will run slower
$(CLEAN_ENV) \
- ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_OPTIONS)
+ ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_CONFIGURE)
touch configure-stamp
@@ -44,7 +51,6 @@ clean:
# commands to clean up after the build process.
-$(MAKE) distclean
- rm -f help_mp.h config.h config.mak
dh_clean
# Build architecture-independent files here.
@@ -61,14 +67,9 @@ binary-arch: build
# commands to install the package into debian/<packagename>
$(MAKE) prefix=$(prefix)/usr BINDIR=$(prefix)/usr/bin CONFDIR=$(prefix)/etc/mplayer LIBDIR=$(prefix)/usr/lib DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
- dh_link usr/bin/mplayer usr/bin/gmplayer \
- usr/share/man/man1/mplayer.1.gz usr/share/man/man1/gmplayer.1.gz
-
-
- dh_installdebconf
+ install -D -m 644 etc/example.conf $(prefix)/etc/mplayer/mplayer.conf
dh_installdocs -X.svn -Xmplayer.1 DOCS/*
dh_installexamples etc/example.conf etc/dvb-menu.conf etc/input.conf etc/menu.conf
- dh_installmenu
dh_installmime
dh_installinfo
dh_installchangelogs