summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Weißschuh <thomas@t-8ch.de>2023-01-19 02:46:26 +0000
committerDudemanguy <random342@airmail.cc>2023-01-19 22:15:14 +0000
commitede8d29408f7cb70b37a60daa03802b8e42c6fb7 (patch)
treee0c3cffd7385e2d67435741e3379afd81118b20f /meson.build
parent491aaacca6528c767cd1b5ba7797dea1c09957ae (diff)
downloadmpv-ede8d29408f7cb70b37a60daa03802b8e42c6fb7.tar.bz2
mpv-ede8d29408f7cb70b37a60daa03802b8e42c6fb7.tar.xz
meson: don't add libmpv and cplayer features to conf_data
Core code should not use these features as it would mean that a libmpv build could change an mpv executable and vice-versa. Also changing one of them should not force a full recompile of the other one through a change to config.h.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 6dffe2105c..c117f5ead6 100644
--- a/meson.build
+++ b/meson.build
@@ -1606,9 +1606,6 @@ configuration = 'meson configure build ' + '-Dprefix=' + get_option('prefix') +
' -Dbuildtype=' + get_option('buildtype') + \
' -Doptimization=' + get_option('optimization')
-features += {'cplayer': get_option('cplayer')}
-features += {'libmpv-' + get_option('default_library'): get_option('libmpv')}
-
# Set config.h
conf_data = configuration_data()
@@ -1645,6 +1642,10 @@ conf_data.set_quoted('MPV_CONFDIR', join_paths(get_option('prefix'), get_option(
configure_file(output : 'config.h', configuration : conf_data)
message('List of enabled features: ' + feature_str)
+# These are intentionally not added to conf_data.
+features += {'cplayer': get_option('cplayer')}
+features += {'libmpv-' + get_option('default_library'): get_option('libmpv')}
+
# build targets
if win32