summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2021-11-14 18:39:25 -0600
committerDudemanguy <random342@airmail.cc>2021-11-15 16:58:23 +0000
commite6ce03f3ef7c12617b32b176f8bb13f4d4349185 (patch)
treed7ecbb7b5ff3694fba5b28f8adf6347f2c5fd020 /meson.build
parentdfbaf4dd81cd19779bfa810b0f838a10c3836963 (diff)
downloadmpv-e6ce03f3ef7c12617b32b176f8bb13f4d4349185.tar.bz2
mpv-e6ce03f3ef7c12617b32b176f8bb13f4d4349185.tar.xz
meson: also check for generic lua.pc
Some systems have only a "lua.pc" file which contains version information inside it. Check those as well.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ed48fd6aa0..b6e6b2159c 100644
--- a/meson.build
+++ b/meson.build
@@ -701,7 +701,8 @@ lua = {
}
lua_opt = get_option('lua')
if lua_opt != 'disabled'
- lua_version = [['lua52', '>= 5.2.0'],
+ lua_version = [['lua', ['>=5.1.0', '<5.3.0']], # generic lua.pc
+ ['lua52', '>= 5.2.0'],
['lua5.2', '>= 5.2.0'],
['lua-5.2', '>= 5.2.0'],
['luajit', '>= 2.0.0'],