summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.dev>2022-02-26 15:13:10 +0100
committerNiklas Haas <github-daiK1o@haasn.dev>2022-03-03 13:06:05 +0100
commite2c02a4ce3af792251839307c42c85aa34bdd125 (patch)
tree031999115b57e51d1a4d81b27ac38c37a7c18160 /meson.build
parent4387f3bcd0744a81011f65f207e76d919f0cda90 (diff)
downloadmpv-e2c02a4ce3af792251839307c42c85aa34bdd125.tar.bz2
mpv-e2c02a4ce3af792251839307c42c85aa34bdd125.tar.xz
hwdec_vaapi_vk: rename to vaapi_pl
There's really nothing vulkan-specific about this hwdec wrapper, and it actually works perfectly fine with an OpenGL-based ra_pl. This is not hugely important at the time, but I still think it makes sense in case we ever decide to make vo_gpu_next wrap OpenGL contexts to ra_pl instead of exposing the underlying ra_gl.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 2af8111c3e..24e207601d 100644
--- a/meson.build
+++ b/meson.build
@@ -1470,16 +1470,16 @@ if vaapi_egl['use']
sources += files('video/out/hwdec/hwdec_vaapi_gl.c')
endif
-vaapi_vulkan = {
- 'name': 'vaapi-vulkan',
- 'use': vaapi['use'] and vulkan.found(),
+vaapi_libplacebo = {
+ 'name': 'vaapi-libplacebo',
+ 'use': vaapi['use'] and libplacebo.found(),
}
-if vaapi_vulkan['use']
- features += vaapi_vulkan['name']
- sources += files('video/out/hwdec/hwdec_vaapi_vk.c')
+if vaapi_libplacebo['use']
+ features += vaapi_libplacebo['name']
+ sources += files('video/out/hwdec/hwdec_vaapi_pl.c')
endif
-if vaapi_egl['use'] or vaapi_vulkan['use']
+if vaapi_egl['use'] or vaapi_libplacebo['use']
sources += files('video/out/hwdec/hwdec_vaapi.c')
endif
@@ -1776,7 +1776,7 @@ conf_data.set10('HAVE_UWP', uwp.found())
conf_data.set10('HAVE_VAAPI', vaapi['use'])
conf_data.set10('HAVE_VAAPI_DRM', vaapi_drm['use'])
conf_data.set10('HAVE_VAAPI_EGL', vaapi_egl['use'])
-conf_data.set10('HAVE_VAAPI_VULKAN', vaapi_vulkan['use'])
+conf_data.set10('HAVE_VAAPI_LIBPLACEBO', vaapi_libplacebo['use'])
conf_data.set10('HAVE_VAAPI_WAYLAND', vaapi_wayland['use'])
conf_data.set10('HAVE_VAAPI_X11', vaapi_x11['use'])
conf_data.set10('HAVE_VAPOURSYNTH', vapoursynth.found() and vapoursynth_script.found())