summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-01-31 13:59:21 -0600
committerDudemanguy <random342@airmail.cc>2023-02-02 14:22:09 +0000
commitcc87a25f7d2ae3f8191741487cdb5da584559026 (patch)
tree8ba571c28c99da028b1d5fe615350dc9b5e425f6 /meson.build
parenta9c5414b86126af955d1d0bbf8a34d16a2f443b7 (diff)
downloadmpv-cc87a25f7d2ae3f8191741487cdb5da584559026.tar.bz2
mpv-cc87a25f7d2ae3f8191741487cdb5da584559026.tar.xz
meson: move vector check inside of meson.build
It's three lines. There's no real reason to have this as a separate file when we've removed every other compile check sourced from outside files.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 753cd94d94..9e37f8e2aa 100644
--- a/meson.build
+++ b/meson.build
@@ -540,10 +540,12 @@ features += {'bsd-fstatfs': cc.has_function('fstatfs', prefix: '#include <sys/mo
features += {'linux-fstatfs': cc.has_function('fstatfs', prefix: '#include <sys/vfs.h>')}
-fragments = join_paths(source_root, 'waftools', 'fragments')
-
+vector_attribute = '''int main() {
+float v __attribute__((vector_size(32)));
+}
+'''
vector = get_option('vector').require(
- cc.compiles(files(join_paths(fragments, 'vector.c')), name: 'vector check'),
+ cc.compiles(vector_attribute, name: 'vector check'),
error_message: 'the compiler does not support gcc vectors!',
)
features += {'vector': vector.allowed()}