summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@overt.org>2022-11-29 11:16:57 -0800
committerPhilip Langdale <github.philipl@overt.org>2022-12-01 10:45:47 -0800
commit70683b891672aba401c111e4afc599ca230d7314 (patch)
tree68a6cf5f899498c9cf0081b7278a61f9ec786c9b /meson.build
parent11229e7f7177220dd1607625a3a1bfc9d34a5f51 (diff)
downloadmpv-70683b891672aba401c111e4afc599ca230d7314.tar.bz2
mpv-70683b891672aba401c111e4afc599ca230d7314.tar.xz
ffmpeg: increase minimum required version to 4.4
Now that 0.35 has been released, we can consider increasing our minimum required ffmpeg version. Currently, we think 4.4 is the most recent version we can move to (from the current requirement of 4.0). This allows us to remove a few conditionals. There are more that we won't be able to remove unless we move further up to 5.1.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 0eb10d4fe1..ae744236b3 100644
--- a/meson.build
+++ b/meson.build
@@ -16,12 +16,12 @@ source_root = meson.project_source_root()
python = find_program('python3')
# ffmpeg
-libavcodec = dependency('libavcodec', version: '>= 58.12.100')
-libavfilter = dependency('libavfilter', version: '>= 7.14.100')
-libavformat = dependency('libavformat', version: '>= 58.9.100')
-libavutil = dependency('libavutil', version: '>= 56.12.100')
-libswresample = dependency('libswresample', version: '>= 3.0.100')
-libswscale = dependency('libswscale', version: '>= 5.0.101')
+libavcodec = dependency('libavcodec', version: '>= 58.134.100')
+libavfilter = dependency('libavfilter', version: '>= 7.110.100')
+libavformat = dependency('libavformat', version: '>= 58.76.100')
+libavutil = dependency('libavutil', version: '>= 56.70.100')
+libswresample = dependency('libswresample', version: '>= 3.9.100')
+libswscale = dependency('libswscale', version: '>= 5.9.100')
libass = dependency('libass', version: '>= 0.12.2')
pthreads = dependency('threads')
@@ -631,7 +631,7 @@ if features['libarchive']
'stream/stream_libarchive.c')
endif
-libavdevice = dependency('libavdevice', version: '>= 57.0.0', required: get_option('libavdevice'))
+libavdevice = dependency('libavdevice', version: '>= 58.13.100', required: get_option('libavdevice'))
features += {'libavdevice': libavdevice.found()}
if features['libavdevice']
dependencies += libavdevice