summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2022-05-04 15:09:48 -0500
committerDudemanguy <random342@airmail.cc>2022-05-05 13:04:15 +0000
commit3a4537d40be9a1b11ca1719d7e34b166bcfb293b (patch)
tree4a22d82c109ff0ad4aea0b8e08e21d513f2f098c /meson.build
parent76f888f5551f486b6d0c9b9c3a0f17e1e0bf9d71 (diff)
downloadmpv-3a4537d40be9a1b11ca1719d7e34b166bcfb293b.tar.bz2
mpv-3a4537d40be9a1b11ca1719d7e34b166bcfb293b.tar.xz
meson: compile mpv.exe as a win32 gui application
Some compiler flags were passed to mpv in order to get it to build as a gui application on windows. However on the meson build, this always resulted in mpv being built as a console application. This is because the function for making executables in meson specifically has a kwarg called win_subsystem* which defaults to 'console'. That always added link arguments at the end which compiled mpv.exe as a console application. The correct thing to do is to remove all of the subsystem-related flags in the meson build and use the win_subsystem kwarg as intended by setting it to 'windows,6.0'. For mpv.com, we can remove the -Wl,--subsystem,console flag since meson will set this by default in that executable. This makes mpv.exe function correctly and open with the pseudo-gui while mpv.com acts as a console wrapper. https://github.com/mesonbuild/meson/commit/1a0603835e3c9f1047d9b7694efc996219a422e4
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 61b26871f1..7f4af53c06 100644
--- a/meson.build
+++ b/meson.build
@@ -297,18 +297,13 @@ endif
mswin_flags = ['-D_WIN32_WINNT=0x0602', '-DUNICODE', '-DCOBJMACROS',
'-DINITGUID', '-U__STRICT_ANSI__']
-mswin_linkflags = ['-Wl,--major-os-version=6,--minor-os-version=0',
- '-Wl,--major-subsystem-version=6,--minor-subsystem-version=0']
-
if host_machine.system() == 'windows'
flags += [mswin_flags, '-D__USE_MINGW_ANSI_STDIO=1']
- link_flags += [mswin_linkflags, '-mwindows']
endif
if host_machine.system() == 'cygwin'
features += 'cygwin'
flags += [mswin_flags, '-mwin32']
- link_flags += mswin_linkflags
endif
noexecstack = false
@@ -1865,6 +1860,6 @@ if get_option('cplayer')
rename: 'mpv.svg')
install_data('etc/mpv-symbolic.svg', install_dir: join_paths(hicolor_dir, 'symbolic', 'apps'))
- executable('mpv', sources, dependencies: dependencies,
+ executable('mpv', sources, dependencies: dependencies, win_subsystem: 'windows,6.0',
include_directories: includedir, install: true)
endif