summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.dev>2022-04-09 23:58:59 +0200
committerNiklas Haas <github-daiK1o@haasn.dev>2022-04-11 15:43:51 +0200
commit26a3a0686179627de6c9bffd45ae4c15a0b37771 (patch)
treed2523ba898c4ca1161767ee81a138035f2301cc1 /meson.build
parent2cafe5137f1544df130face8f748cc571ddf0445 (diff)
downloadmpv-26a3a0686179627de6c9bffd45ae4c15a0b37771.tar.bz2
mpv-26a3a0686179627de6c9bffd45ae4c15a0b37771.tar.xz
vo_gpu_next: switch to unpooled hwdec mapping
This makes use of the new frame acquire/release callbacks to hold on to hwdec images only as long as necessary. This should greatly improve the smoothness/efficiency of hwdec interop, by not holding on to them for longer than needed. This also avoids the need to pool hwdec mappers altogether. Should fix #10067 as well, since frames are now only mapped when we actually use them.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 24e207601d..42e6624c95 100644
--- a/meson.build
+++ b/meson.build
@@ -965,14 +965,14 @@ if libplacebo.found()
sources += files('video/out/placebo/ra_pl.c',
'video/out/placebo/utils.c')
pl_api_ver = libplacebo.version().split('.')[1]
- if pl_api_ver.version_compare('>=199')
+ if pl_api_ver.version_compare('>=202')
features += 'libplacebo-next'
libplacebo_next = true
- message('libplacebo v4.199+ found! Enabling vo_gpu_next.')
+ message('libplacebo v4.202+ found! Enabling vo_gpu_next.')
sources += files('video/out/vo_gpu_next.c',
'video/out/gpu_next/context.c')
else
- message('libplacebo v4.199+ not found! Disabling vo_gpu_next.')
+ message('libplacebo v4.202+ not found! Disabling vo_gpu_next.')
endif
endif